Bug 534570 - (RHQ-1354) Investigate use of additional indices on tables we purge from
Investigate use of additional indices on tables we purge from
Status: CLOSED NOTABUG
Product: RHQ Project
Classification: Other
Component: Performance (Show other bugs)
1.2
All All
medium Severity medium (vote)
: ---
: ---
Assigned To: Joseph Marques
http://jira.rhq-project.org/browse/RH...
: Task
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-13 09:35 EST by Charles Crouch
Modified: 2015-02-01 18:24 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Charles Crouch 2009-01-13 09:35:00 EST
We should do some investigation into whether our purge process could be improved by having some additional indexes, e.g on the TIME_STAMP columns, on tables we could end up deleting a lot of rows from, e.g. events, 1h, 6h, 1d tables. We obviously need to also make sure that insert performance is not significantly impacted by having to update any new index.
Comment 1 Joseph Marques 2009-01-13 10:30:22 EST
i've also seen some table contention issues in the alert subsystem.  if there is load on the system, and you try to update an alert template, it will not always completely successfully.  ugly stack in the ui.
Comment 2 Joseph Marques 2009-09-04 18:05:27 EDT
duplicate of RHQ-2376, which is already resolved
Comment 3 Red Hat Bugzilla 2009-11-10 15:31:12 EST
This bug was previously known as http://jira.rhq-project.org/browse/RHQ-1354
This bug is related to RHQ-1336

Note You need to log in before you can comment on or make changes to this bug.