Bug 534669 - (RHQ-1443) need new agentspawn scripts to test agent auto upgrade
need new agentspawn scripts to test agent auto upgrade
Status: CLOSED NEXTRELEASE
Product: RHQ Project
Classification: Other
Component: Tests (Show other bugs)
unspecified
All All
high Severity medium (vote)
: ---
: ---
Assigned To: John Mazzitelli
http://jira.rhq-project.org/browse/RH...
: Task
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-30 11:36 EST by John Mazzitelli
Modified: 2009-02-03 12:18 EST (History)
0 users

See Also:
Fixed In Version: 1.2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Mazzitelli 2009-01-30 11:36:00 EST
Need to create some additional agentspawn test scripts so we can test agent auto-update.

The current agentspawn allows for multiple agents to run in a single VM, but as such, makes it unable to be auto-updated (because the file layout is different than the normal agent distro).

We need an ant script that copies N agents into their own distribution directories and runs them all individually. As if you installed N agents manually and ran them all.

On the server side, we need the ability to stamp an agent binary update located in rhq-downloads/rhq-agent with a bogus version number so all agents that connect to the server are considered to be violating the prime directive and therefore considered "out of date".
Comment 1 John Mazzitelli 2009-01-30 22:16:39 EST
Some docs on the new agentcopy

http://support.rhq-project.org/display/RHQ/Design-AgentSpawn#Design-AgentSpawn-AgentCopy
Comment 2 John Mazzitelli 2009-01-31 03:34:06 EST
scripts for agentcopy are done.
scripts to stamp server's agent update binary are done.
Comment 3 Red Hat Bugzilla 2009-11-10 15:33:06 EST
This bug was previously known as http://jira.rhq-project.org/browse/RHQ-1443

Note You need to log in before you can comment on or make changes to this bug.