Bug 534705 - (RHQ-1476) Breadcrumbs do not appear on next page after submitting schedule changes to Metric Templates
Breadcrumbs do not appear on next page after submitting schedule changes to M...
Status: CLOSED NEXTRELEASE
Product: RHQ Project
Classification: Other
Component: Usability (Show other bugs)
unspecified
All All
low Severity medium (vote)
: ---
: ---
Assigned To: Simeon Pinder
Simeon Pinder
http://jira.rhq-project.org/browse/RH...
: Improvement
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-04 10:25 EST by Mark Burchard
Modified: 2009-04-03 07:12 EDT (History)
1 user (show)

See Also:
Fixed In Version: 1.2
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
N/A
Last Closed:
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mark Burchard 2009-02-04 10:25:00 EST
Breadcrumbs do not appear on the next screen after the flow: 

Administration > Monitoring Defaults > (Utilized types only|All types) > Edit Metric Template > (select metric) > (new value) > submit |> 

You have to go back to Administration and start over for the next metric template, which is cumbersome.  The back button will take you back to the previous screen, but that breaks the intended page flow.
Comment 1 Simeon Pinder 2009-03-27 15:25:02 EDT
It appears that this issue may be caused by the fact that two different struts actions are used during this one operation and the context(i.e. Bread Crumb listin) is not transferred correctly.   In other words, before the change is committed, navigation and template details are displayed by the following url :

http://127.0.0.1:7080/admin/platform/monitor/Config.do?mode=configure&id=502077&type=502077

      during or after the change is committed, the struts action and url looks like 

http://127.0.0.1:7080/resource/common/monitor/config/ConfigMetrics.do 

The correct fix is probably to migrate this struts page to JSF correctly but that may not be the right course of action given the time constraints.
 
Comment 2 Simeon Pinder 2009-04-03 07:05:23 EDT
Modified struts-config.xml to forward action and validation results to the original admin/common context. See SVN 3589 for more details.  Modified and tested and struts style breadcrumbs are correctly displayed.
Comment 3 Red Hat Bugzilla 2009-11-10 15:33:47 EST
This bug was previously known as http://jira.rhq-project.org/browse/RHQ-1476

Note You need to log in before you can comment on or make changes to this bug.