This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 534711 - (RHQ-1481) Have Events tab show up only when the resource type supports events
Have Events tab show up only when the resource type supports events
Status: CLOSED NEXTRELEASE
Product: RHQ Project
Classification: Other
Component: Core UI (Show other bugs)
unspecified
All All
medium Severity medium (vote)
: ---
: ---
Assigned To: Joseph Marques
Jeff Weiss
http://jira.rhq-project.org/browse/RH...
: Improvement
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-05 10:17 EST by Charles Crouch
Modified: 2015-02-01 18:25 EST (History)
2 users (show)

See Also:
Fixed In Version: 1.2
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Charles Crouch 2009-02-05 10:17:00 EST
Right now the Event tab shows up between Monitor and Inventory on every resource regardless of whether that resource generates events or not. This is the opposite to how the other tabs work, e.g. Content, Operations, which only appear when the type of the resource supports that feature.
Comment 1 John Mazzitelli 2009-02-05 10:19:24 EST
the Events tab is how you also get to the timeline - and that should be visible for all resources (since it shows alerts, config changes, avail changes, etc)
Comment 2 Joseph Marques 2009-02-05 10:21:34 EST
mazz, true, though maybe the timeline stuff shouldn't be in the events tab.  maybe it needs it's own tab altogether since it cross availability, events, operations, alerts, etc
Comment 3 John Mazzitelli 2009-02-05 10:23:48 EST
all the tabs today represent distinct subsystems (Operations, Monitoring, Alerts, Configuration, etc).

The timeline doesn't really fit into the category of a "subsystem" - its a place where all the subsystems aggregate their information into one view. Its kinda like the "subsystems" view, but across a single resource, not the entire inventory.

So, I don't think timeline should be on its own tab, but I don't know where it should go :)
Comment 4 Joseph Marques 2009-02-06 12:26:21 EST
the monitor tab has monitoring data, but it also has availability as well as events
the alerts tab has alerts as well as the operations that were triggered as part of an alert being fired
Comment 5 Joseph Marques 2009-02-13 21:00:04 EST
rev3054 - the 'e' icon will only show up for resources that support events, or compatible groups containing resources that support it; 
Comment 6 John Mazzitelli 2009-02-13 21:05:59 EST
where is the link to the timeline now?
Comment 7 Joseph Marques 2009-02-14 01:26:10 EST
i'm willing to put it anywhere that makes sense.  i'm leaning towards making it into it's own tab -- thoughts?
Comment 8 Heiko W. Rupp 2009-02-14 08:02:48 EST
That would be ok, but give yet another icon ... But now that the TL works :) OTOH If Events is only the history then, we can put it back under Monitor.
Comment 9 John Mazzitelli 2009-02-14 10:10:36 EST
since its an aggregation of all the other subsystems, I would think it makes the most sense as a tab inside the subsystems page
Comment 10 Joseph Marques 2009-02-14 19:28:27 EST
see the screenshot from the linked jira.
Comment 11 Jeff Weiss 2009-03-06 13:17:15 EST
Only see events tab for supported resource types. rev3238
Comment 12 Red Hat Bugzilla 2009-11-10 15:33:54 EST
This bug was previously known as http://jira.rhq-project.org/browse/RHQ-1481
This bug relates to RHQ-1575

Note You need to log in before you can comment on or make changes to this bug.