Bug 534796 - (RHQ-1558) purge user preference cache until session timeout or explicit user logout action
purge user preference cache until session timeout or explicit user logout action
Status: CLOSED NEXTRELEASE
Product: RHQ Project
Classification: Other
Component: Configuration (Show other bugs)
unspecified
All All
medium Severity medium (vote)
: ---
: ---
Assigned To: Joseph Marques
Corey Welton
http://jira.rhq-project.org/browse/RH...
: Improvement
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-12 15:09 EST by Joseph Marques
Modified: 2009-03-28 00:13 EDT (History)
0 users

See Also:
Fixed In Version: 1.2
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Joseph Marques 2009-02-12 15:09:00 EST
since RHQ-1544 pushes the preferences cache down into the server/jar layer, we can't rely on the http session automatically purging things for us.  instead, we have to listen for session timeout events as well as explicitly logout events from web users and purge the cache manually in those two instances.
Comment 1 Joseph Marques 2009-02-12 15:14:30 EST
rev3037 - explicitly purge the user's preferences cache upon session timeout or logout action; 
Comment 2 Joseph Marques 2009-02-12 15:17:38 EST
to verify, add this entry to your jboss-log4j.xml file for the server:

   <category name="org.rhq.enterprise.server.auth.prefs.SubjectPreferencesCache">
     <priority value="TRACE"/>
   </category>

in the same file, change the ConsoleAppender threshold to TRACE:

<param name="Threshold" value="TRACE"/>

in the web.xml change the timeout to 1 minute:

   <session-config>
      <session-timeout>1</session-timeout>
   </session-config>

log into the application, log out of the application, verify you see the following message: Removing PreferencesCache For {subjectId}
log into the application, wait 1 minute for session timeout, verify you see the message: Removing PreferencesCache For {subjectId}
Comment 3 Corey Welton 2009-03-28 00:13:55 EDT
Testing notes: "Removing PreferencesCache For {subjectId} " references to appear in server log.

QA Verified.  After making changes, PreferencesCache message appears in server log for both of these scenarios.
Comment 4 Red Hat Bugzilla 2009-11-10 15:35:35 EST
This bug was previously known as http://jira.rhq-project.org/browse/RHQ-1558

Note You need to log in before you can comment on or make changes to this bug.