Bug 53485 - magicdev crashes on startup
magicdev crashes on startup
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: magicdev (Show other bugs)
7.1
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Owen Taylor
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-09-10 07:44 EDT by jeroen
Modified: 2007-04-18 12:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-09-11 03:02:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description jeroen 2001-09-10 07:44:43 EDT
Description of Problem:

magicdev crashes on a clean rh7.1 install with Ximian Gnome 1.4 installed
on top of that. It immediately displays several crash dialogs (behind each
other) of multiple magicdev processes that have all crashed. Upgrading to
the latest magicdev version from the Roswell 7.2 beta didn't help. I didn't
find any magicdev messages in /var/log/messages. I have a standard floppy
drive and a standard cd-rom drive. Nautilus (1.0.4 from red-carpet) is my
default desktop.

Version-Release number of selected component (if applicable):
0.3.6

How Reproducible:
Every time

Steps to Reproduce:
1.  Start linux
2.  Login (graphical login)
3.  Nautilus starts -> magicdev crashes

Actual Results:


Expected Results:


Additional Information:
(generated by bug-buddy)
Debugging Information:

(no debugging symbols found)...0x40579519 in __wait4 ()
   from /lib/i686/libc.so.6
#0  0x40579519 in __wait4 () from /lib/i686/libc.so.6
#1  0x405e99e4 in __DTOR_END__ () from /lib/i686/libc.so.6
#2  0x4008f262 in gnome_segv_handle (signum=11) at gnome-init.c:659
#3  <signal handler called>
#4  fgets_unlocked (buf=0x8093d90 "`\177^@`\177^@E/Applet:1.0", n=4096,
fp=0x0)
    at iofgets_u.c:44
#5  0x405a05f4 in __getmntent_r (stream=0x0, mp=0x405ebf80, 
    buffer=0x8093d90 "`\177^@`\177^@E/Applet:1.0", bufsiz=4096)
    at mntent_r.c:103
#6  0x405a050f in getmntent (stream=0x0) at mntent.c:53
#7  0x0804afc0 in main () at eval.c:41
#8  0x0804b08b in main () at eval.c:41
#9  0x0804ad84 in main () at eval.c:41
#10 0x404db177 in __libc_start_main (main=0x804ac80 <main>, argc=3, 
    ubp_av=0xbffffbec, init=0x804a408 <_init>, fini=0x804d4b0 <_fini>, 
    rtld_fini=0x4000e184 <_dl_fini>, stack_end=0xbffffbdc)
    at ../sysdeps/generic/libc-start.c:129
#0  0x40579519 in __wait4 () from /lib/i686/libc.so.6
No locals.
#1  0x405e99e4 in __DTOR_END__ () from /lib/i686/libc.so.6
No symbol table info available.
#2  0x4008f262 in gnome_segv_handle (signum=11) at gnome-init.c:659
	in gnome-init.c
estatus = 1077828024
in_segv = 1
pid = 0
#3  <signal handler called>
No locals.
#4  fgets_unlocked (buf=0x8093d90 "`\177^@`\177^@E/Applet:1.0", n=4096,
fp=0x0)
    at iofgets_u.c:44
	in iofgets_u.c
n = 0
fp = (_IO_FILE *) 0x0
count = 3221222936
result = 0xfffffe00 <Address 0xfffffe00 out of bounds>
old_error = 1078266044
count = 3221222936
old_error = 1078266044
#5  0x405a05f4 in __getmntent_r (stream=0x0, mp=0x405ebf80, 
    buffer=0x8093d90 "`\177^@`\177^@E/Applet:1.0", bufsiz=4096)
    at mntent_r.c:103
	in mntent_r.c
cp = 0xfffffe00 <Address 0xfffffe00 out of bounds>
head = 0x8092cb8 "\002"
head = 0x8092cb8 "\002"
#6  0x405a050f in getmntent (stream=0x0) at mntent.c:53
	in mntent.c
m = {mnt_fsname = 0x0, mnt_dir = 0x0, mnt_type = 0x0, mnt_opts = 0x0, 
  mnt_freq = 0, mnt_passno = 0}
once = 1
m = {mnt_fsname = 0x0, mnt_dir = 0x0, mnt_type = 0x0, mnt_opts = 0x0, 
  mnt_freq = 0, mnt_passno = 0}
once = 1
#7  0x0804afc0 in main () at eval.c:41
	in eval.c
ap = (void **) 0x0
digval = 4294966784
digval = 4294966784
digval = 4294966784
digval = 4294966784
p = 0x0
result = 0
result = 0
Comment 1 Owen Taylor 2001-09-10 09:58:13 EDT
Hmmm, my guess here is that your /etc/fstab is not world readable
due to a local change. (magicdev should handle this gracefully
and not segfault, of course.)

Can you confirm this?
Comment 2 jeroen 2001-09-11 03:02:45 EDT
Correct, /etc/fstab contains a samba and novell share which both use my own
login & password. I therefore made fstab only readable for root.

-rw-------    1 root     root          749 Sep 10 11:58 /etc/fstab
Comment 3 Owen Taylor 2001-09-26 15:19:05 EDT
Fixed pacakges can be found in:

 http://people.redhat.com/otaylor/magicdev/

Note You need to log in before you can comment on or make changes to this bug.