Bug 534882 - (RHQ-1635) should append to rhq-server-log4j.log, not overwrite, on RHQ server restart
should append to rhq-server-log4j.log, not overwrite, on RHQ server restart
Status: CLOSED NEXTRELEASE
Product: RHQ Project
Classification: Other
Component: No Component (Show other bugs)
unspecified
All All
medium Severity medium (vote)
: ---
: ---
Assigned To: Joseph Marques
Jeff Weiss
http://jira.rhq-project.org/browse/RH...
: Improvement
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-02-23 10:15 EST by Charles Crouch
Modified: 2015-02-01 18:25 EST (History)
2 users (show)

See Also:
Fixed In Version: 1.2
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Charles Crouch 2009-02-23 10:15:00 EST

    
Comment 1 Joseph Marques 2009-02-25 00:34:21 EST
rev3182 - too often do people restart their server due to issues and lose logs (and thus can't submit to dev for figuring out what happened), this is an attempt to remedy that situation; 
Comment 2 Jeff Weiss 2009-03-09 11:22:52 EDT
Fixed, rev3238:

[jonqa@witte bin]$ ls -al ../logs/
total 7088
drwxrwxr-x 2 jonqa jonqa    4096 Mar  8 03:00 .
drwxrwxr-x 6 jonqa jonqa    4096 Mar  2 11:59 ..
-rw-rw-r-- 1 jonqa jonqa   77927 Mar  2 11:59 boot.log
-rw-rw-r-- 1 jonqa jonqa   24310 Mar  2 12:02 db-data-combined.xml
-rw-rw-r-- 1 jonqa jonqa   87560 Mar  2 12:02 db-schema-combined.xml
-rw-rw-r-- 1 jonqa jonqa 1721496 Mar  9 11:00 rhq-server-log4j.log
-rw-rw-r-- 1 jonqa jonqa 5275418 Mar  8 03:00 rhq-server-log4j.log.1
[jonqa@witte bin]$ ./rhq-server.sh stop
Trying to stop the RHQ Server...
RHQ Server (pid=14351) is stopping...
RHQ Server has stopped.
[jonqa@witte bin]$ ./rhq-server.sh start
Trying to start the RHQ Server...
RHQ Server (pid 20751) is starting
[jonqa@witte bin]$ ls -al ../logs/
total 7152
drwxrwxr-x 2 jonqa jonqa    4096 Mar  8 03:00 .
drwxrwxr-x 6 jonqa jonqa    4096 Mar  2 11:59 ..
-rw-rw-r-- 1 jonqa jonqa   77876 Mar  9 11:18 boot.log
-rw-rw-r-- 1 jonqa jonqa   24310 Mar  2 12:02 db-data-combined.xml
-rw-rw-r-- 1 jonqa jonqa   87560 Mar  2 12:02 db-schema-combined.xml
-rw-rw-r-- 1 jonqa jonqa 1787816 Mar  9 11:20 rhq-server-log4j.log
-rw-rw-r-- 1 jonqa jonqa 5275418 Mar  8 03:00 rhq-server-log4j.log.1
[jonqa@witte bin]$ 
Comment 3 Red Hat Bugzilla 2009-11-10 15:37:11 EST
This bug was previously known as http://jira.rhq-project.org/browse/RHQ-1635

Note You need to log in before you can comment on or make changes to this bug.