Bug 534969 - (RHQ-1713) Investigate whether an additional index is needed on RHQ_RESOURCE_ERROR
Investigate whether an additional index is needed on RHQ_RESOURCE_ERROR
Status: CLOSED NEXTRELEASE
Product: RHQ Project
Classification: Other
Component: Performance (Show other bugs)
1.0
All All
medium Severity medium (vote)
: ---
: ---
Assigned To: Joseph Marques
http://jira.rhq-project.org/browse/RH...
: Task
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-03 13:21 EST by Charles Crouch
Modified: 2015-02-01 18:25 EST (History)
1 user (show)

See Also:
Fixed In Version: 1.2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Charles Crouch 2009-03-03 13:21:00 EST
See case 269460 for details.

The original SQL which was identified in the case as a bottleneck is no longer used in the main code base so the immediate problem should have been addressed. However I think there is the potential for similar problems with the query ResourceError.QUERY_FIND_BY_RESOURCE_ID_AND_ERROR_TYPE

RHQ-1671 was raised to reduce the number of unnecessary calls to this query, but it turns out that code path is no longer being executed either, more good news. However we should investigate and see if there are any other usages of this query that could result in it getting executed a large number of times.

Comment 1 Joseph Marques 2009-03-05 22:32:48 EST
rev3322 - add index to resourceId column of ResourceError object, which all queries are currently keyed off of; 
Comment 2 Red Hat Bugzilla 2009-11-10 15:38:56 EST
This bug was previously known as http://jira.rhq-project.org/browse/RHQ-1713

Note You need to log in before you can comment on or make changes to this bug.