Bug 535078 - (RHQ-1810) add double-check pattern to resource jobs that are part of group jobs
add double-check pattern to resource jobs that are part of group jobs
Status: CLOSED NEXTRELEASE
Product: RHQ Project
Classification: Other
Component: Configuration (Show other bugs)
1.1
All All
medium Severity medium (vote)
: ---
: ---
Assigned To: Joseph Marques
http://jira.rhq-project.org/browse/RH...
: Task
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-18 15:43 EDT by Joseph Marques
Modified: 2009-03-24 14:31 EDT (History)
0 users

See Also:
Fixed In Version: 1.2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
rhq-1810-problem-solution.txt (1.69 KB, text/plain)
2009-03-18 15:48 EDT, Joseph Marques
no flags Details

  None (edit)
Description Joseph Marques 2009-03-18 15:43:00 EDT
see txt file attachment for a diagrammatic discussion of the problem and solution
Comment 1 Joseph Marques 2009-03-23 09:15:57 EDT
after some quick investigation, this needs to be done in two places:

* when committing the asynchronous callback for the completion of the ResourceConfigurationUpdate (because it may be part of a larger group update)
* when committing the asynchronous callback for the completion of the ResourceOperationHistory (because it may be part of a large group history)

note: as of the date of this writing, this does /not/ need to be done for plugin configuration because that logic occurs synchronously when called.  i.e., it will block the caller until the plugin configuration on the agent-side resource is updated.  thus, group plugin configuration updates are implicitly serialized and do not suffer from the same isolation issues described in the corresponding attachment.
Comment 2 Joseph Marques 2009-03-23 10:50:28 EDT
rev3501 - work around issues where group operations / group config updates would remain INPROGRESS if the last resource ops / resource config updates were executing at the same time; 
Comment 3 Red Hat Bugzilla 2009-11-10 15:47:10 EST
This bug was previously known as http://jira.rhq-project.org/browse/RHQ-1810
Imported an attachment (id=368649)

Note You need to log in before you can comment on or make changes to this bug.