Bug 535136 - (RHQ-1863) test resource permission: Measure
test resource permission: Measure
Status: CLOSED NEXTRELEASE
Product: RHQ Project
Classification: Other
Component: No Component (Show other bugs)
unspecified
All All
high Severity medium (vote)
: ---
: ---
Assigned To: Simeon Pinder
http://jira.rhq-project.org/browse/RH...
: SubTask
Depends On:
Blocks: RHQ-1848
  Show dependency treegraph
 
Reported: 2009-03-26 13:33 EDT by John Mazzitelli
Modified: 2009-11-10 16:22 EST (History)
0 users

See Also:
Fixed In Version: 1.2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Mazzitelli 2009-03-26 13:33:00 EDT

    
Comment 1 John Mazzitelli 2009-03-26 13:46:00 EDT
Test that the  measurement permission works. I think the only thing this gives you permission to do is to change the collection intervals for metric schedules. Someone correct me if I'm wrong. Who ever is assigned to this needs to check the code to make sure I'm right.
Comment 2 Simeon Pinder 2009-04-08 13:56:09 EDT
1) Created 'Everything' group including all discovered resources(See parent issue for details).
2) Create two additional user accounts i) u:none with no role perms and member of everything group. ii)u:measure w/ 'measure' perms and member of 'Everything'
3) Logged into the app from three separate browsers(FFx2 & IE) with three separate accounts

Following results obtained while viewing/testing " Logged in-> Resources -> Platforms->[Select One] -> Click on [Free Memory].  At the bottom of the page focus on modifying one of the properties under 'Metric Baseline & Expected Range ':

#u:none - details shown but NO 'Change Value' link is available.
#u:measure - details shown and ABLE to edit/change the 'High Range' and successfully persist to JON inventory.
#u:rhqadmin - details shown and ABLE to edit/change the 'High Range' and successfully persist to JON inventory.

Also checked to see if the edit url could be accessed from the user 'none', but errored out and doesn't appear to be enough context from url anyway.
Ex. Use http://127.0.0.1:7080/resource/common/monitor/visibility/ViewChart.do

The 'none' user could NOT see the edit page link correctly.

SUMMARY:  working as expected. 
Comment 3 Simeon Pinder 2009-04-14 03:16:50 EDT
Added one more level of restricted visibility group testing due to changes in group authorization mechanism. See parent issue for more detailed description.

In addition to above, also created:
i) Recursive group that included the Platform only.
ii) Role that included group from first step and only 'measure' perms selected.
ii) User attached to role.

Works as expected.
Comment 4 Simeon Pinder 2009-04-14 03:17:30 EDT
Nothing additional to report.
Comment 5 Red Hat Bugzilla 2009-11-10 15:48:21 EST
This bug was previously known as http://jira.rhq-project.org/browse/RHQ-1863

Note You need to log in before you can comment on or make changes to this bug.