Bug 535189 - (RHQ-1911) log a warning if agent is registering with a loopback address
log a warning if agent is registering with a loopback address
Status: CLOSED NEXTRELEASE
Product: RHQ Project
Classification: Other
Component: Agent (Show other bugs)
unspecified
All All
low Severity medium (vote)
: ---
: ---
Assigned To: John Mazzitelli
Corey Welton
http://jira.rhq-project.org/browse/RH...
: Improvement
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-01 16:15 EDT by John Mazzitelli
Modified: 2009-04-06 14:44 EDT (History)
0 users

See Also:
Fixed In Version: 1.2
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description John Mazzitelli 2009-04-01 16:15:00 EDT
registering an agent with a loopback address (localhost or 127.0.0.1) is only for testing/demoing the agent. you should never do this in production because that agent will only ever be able to interact with a server on the same box (e.g. agent cannot participate in HA).

Log warnings in both agent and server log files when an agent registers with a loopback.  The functionality should not change - the agent can still register and work as before, this is just to log a message to inform people when this happens in case there was a problem with DNS mappings that a user isn't aware of (or perhaps they entered the wrong values in the setup prompts).

Comment 1 John Mazzitelli 2009-04-01 16:18:31 EDT
Agent log message:

2009-04-01 16:12:04,078 WARN  [RHQ Agent Registration Thread] (org.rhq.enterprise.agent.AgentMain)- {AgentMain.registering-with-loopback}This agent is registering under the loopback address [socket://127.0.0.1:16163/?rhq.communications.connector.rhqtype=agent&numAcceptThreads=1&maxPoolSize=303&clientMaxPoolSize=304&socketTimeout=60000&enableTcpNoDelay=true&backlog=200] - this should only be done for testing or demo purposes - this agent will only be able to interact with a server running on the same host as this agent

Server log message:

16:12:04,171 WARN  [CoreServerServiceImpl] An agent [mazzthink] has registered with a loopback address. This should only be done for testing or demo purposes - this agent can only ever interact with this server. AgentRegistrationRequest: [name=[mazzthink]; address=127.0.0.1]; port=16163]; remote-endpoint=socket://127.0.0.1:16163/?rhq.communications.connector.rhqtype=agent&numAcceptThreads=1&maxPoolSize=303&clientMaxPoolSize=304&socketTimeout=60000&enableTcpNoDelay=true&backlog=200]; regenerate-token=false]; original-token=<was null>]; agent-version=1.2.0-SNAPSHOT(3357)]
Comment 2 Corey Welton 2009-04-06 14:44:49 EDT
This is verified.  Thanks for fixing this one :).
Comment 3 Red Hat Bugzilla 2009-11-10 15:49:18 EST
This bug was previously known as http://jira.rhq-project.org/browse/RHQ-1911
This bug is related to RHQ-1908

Note You need to log in before you can comment on or make changes to this bug.