Bug 53522 - Kedit crashes
Kedit crashes
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: kdeutils (Show other bugs)
7.3
ia64 Linux
medium Severity medium
: ---
: ---
Assigned To: Bernhard Rosenkraenzer
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-09-10 16:42 EDT by Josep L. Guallar-Esteve
Modified: 2007-04-18 12:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-09-17 16:09:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Kdevelop traceback (2.12 KB, text/plain)
2001-09-11 09:27 EDT, Josep Guallar-Esteve
no flags Details

  None (edit)
Description Josep Guallar-Esteve 2001-09-10 16:42:43 EDT
* test tree re0908.2
* test case ia64 / English / NFS / Everything / GUI Install

Description of Problem:

Kedit crashes when trying to do a "File -> Save As ..."


The traceback:

 (no debugging symbols found)...(no debugging symbols found)...
0x20000000020529e2 in wait4 () at soinit.c:56
        in soinit.c
#0  0x20000000020529e2 in wait4 () at soinit.c:56
#1  0x2000000002052960 in __libc_waitpid (pid=1548, stat_loc=0x0, 
options=0)
    at ../sysdeps/unix/sysv/linux/waitpid.c:26
#2  0x2000000000dd3180 in KCrash::defaultCrashHandler ()
   from /usr/lib/libkdecore.so.3
#3  <signal handler called>
#4  0x2000000001ff2190 in strcmp () at soinit.c:56
#5  0x2000000001c03940 in XFreeFontSet () from /usr/X11R6/lib/libX11.so.6
#6  0x2000000001c03f20 in XCreateIC () from /usr/X11R6/lib/libX11.so.6
#7  0x20000000012ccac0 in QWidget::setMicroFocusHint ()
   from /usr/lib/qt-2.3.1/lib/libqt.so.2
#8  0x20000000014ce150 in QLineEdit::paintEvent ()
   from /usr/lib/qt-2.3.1/lib/libqt.so.2
#9  0x2000000001448260 in QWidget::event ()
   from /usr/lib/qt-2.3.1/lib/libqt.so.2
#10 0x20000000014ce540 in QLineEdit::event ()
   from /usr/lib/qt-2.3.1/lib/libqt.so.2
#11 0x20000000012e4d20 in QApplication::notify ()
   from /usr/lib/qt-2.3.1/lib/libqt.so.2
#12 0x2000000000c66080 in KApplication::notify () from 
/usr/lib/libkdecore.so.3
#13 0x20000000012d0480 in QWidget::repaint ()
   from /usr/lib/qt-2.3.1/lib/libqt.so.2
#14 0x20000000014d4ad0 in QLineEdit::blinkSlot ()
   from /usr/lib/qt-2.3.1/lib/libqt.so.2
#15 0x20000000014d90a0 in QLineEdit::blinkOn ()
   from /usr/lib/qt-2.3.1/lib/libqt.so.2
#16 0x20000000014cca50 in QLineEdit::focusInEvent ()
   from /usr/lib/qt-2.3.1/lib/libqt.so.2
#17 0x2000000001448260 in QWidget::event ()
   from /usr/lib/qt-2.3.1/lib/libqt.so.2
#18 0x20000000014ce540 in QLineEdit::event ()
   from /usr/lib/qt-2.3.1/lib/libqt.so.2
#19 0x20000000012e4d20 in QApplication::notify ()
   from /usr/lib/qt-2.3.1/lib/libqt.so.2
#20 0x2000000000c66080 in KApplication::notify () from 
/usr/lib/libkdecore.so.3
#21 0x2000000001442480 in QWidget::setFocus ()
   from /usr/lib/qt-2.3.1/lib/libqt.so.2
#22 0x20000000012e8800 in QApplication::setActiveWindow ()
   from /usr/lib/qt-2.3.1/lib/libqt.so.2
#23 0x2000000001268ad0 in QApplication::x11ProcessEvent ()
   from /usr/lib/qt-2.3.1/lib/libqt.so.2
#24 0x2000000001266170 in QApplication::processNextEvent ()
   from /usr/lib/qt-2.3.1/lib/libqt.so.2
#25 0x20000000012e97f0 in QApplication::enter_loop ()
   from /usr/lib/qt-2.3.1/lib/libqt.so.2
#26 0x20000000012f5f50 in QDialog::show ()
   from /usr/lib/qt-2.3.1/lib/libqt.so.2
#27 0x2000000000250ec0 in KFileDialog::show () from /usr/lib/libkfile.so.3
#28 0x20000000012f4db0 in QDialog::exec ()
   from /usr/lib/qt-2.3.1/lib/libqt.so.2
#29 0x20000000025b7710 in KTextFileDialog::getSaveURLwithEncoding ()
   from /usr/lib/kde2/kedit.so
#30 0x20000000025a3ff0 in TopLevel::file_save_as () from 
/usr/lib/kde2/kedit.so
#310x200000000139f9f0 in QObject::activate_signal ()
   from /usr/lib/qt-2.3.1/lib/libqt.so.2
#32 0x2000000000a33cf0 in KAction::activated () from 
/usr/lib/libkdeui.so.3
#33 0x2000000000a2e860 in KAction::slotActivated () from 
/usr/lib/libkdeui.so.3
#34 0x20000000013a00c0 in QObject::activate_signal ()
   from /usr/lib/qt-2.3.1/lib/libqt.so.2
#35 0x2000000001410570 in QSignal::activate ()
   from /usr/lib/qt-2.3.1/lib/libqt.so.2
#36 0x200000000157e640 in QPopupMenu::mouseReleaseEvent ()
   from /usr/lib/qt-2.3.1/lib/libqt.so.2
#37 0x2000000001448260 in QWidget::event ()
   from /usr/lib/qt-2.3.1/lib/libqt.so.2
#38 0x20000000012e4d20 in QApplication::notify ()
   from /usr/lib/qt-2.3.1/lib/libqt.so.2
#39 0x2000000000c66080 in KApplication::notify () from 
/usr/lib/libkdecore.so.3
#40 0x200000000126ede0 in QETWidget::translateMouseEvent ()
   from /usr/lib/qt-2.3.1/lib/libqt.so.2
#41 0x20000000012688e0 in QApplication::x11ProcessEvent ()
   from /usr/lib/qt-2.3.1/lib/libqt.so.2
#42 0x2000000001266170 in QApplication::processNextEvent ()
   from /usr/lib/qt-2.3.1/lib/libqt.so.2
#43 0x20000000012e97f0 in QApplication::enter_loop ()
   from /usr/lib/qt-2.3.1/lib/libqt.so.2
#44 0x2000000001266070 in QApplication::exec ()
   from /usr/lib/qt-2.3.1/lib/libqt.so.2
#45 0x20000000025aed60 in main () from /usr/lib/kde2/kedit.so
#46 0x400000000000ac10 in _init ()
Comment 1 Bernhard Rosenkraenzer 2001-09-11 05:14:57 EDT
This is almost certainly a compiler bug since it works everywhere else (even 
on other 64-bit arches: alpha, s390x).
Adding Cc.

Comment 2 Bernhard Rosenkraenzer 2001-09-11 05:16:32 EDT
Probably the same problem (Qt or kdelibs miscompilation) as 53521
Comment 3 Jakub Jelinek 2001-09-11 05:20:56 EDT
If it is some eh problem, this needs to be retested when all of kde is rebuilt
with gcc-2.96-98 and above. Otherwise I need a testcase.
Comment 4 Josep Guallar-Esteve 2001-09-11 09:26:19 EDT
* test tree re0908.2
* test case ia64 / English / NFS / Full Workstation / TUI Install

I tried running Kdevelop and got the traceback from the atached file 
kdevelop.log . It seems to be complaining on qt-2.x.x.x library this time. 

Maybe they are the guilty package? (qt-2 seems to me to be the connection 
between kdebase, kdeutils and qt-2).
Comment 5 Josep Guallar-Esteve 2001-09-11 09:27:25 EDT
Created attachment 31597 [details]
Kdevelop traceback
Comment 6 Josep Guallar-Esteve 2001-09-17 16:09:51 EDT
Still happens here:

* test tree re0917.1  IA64
* test case IA64 / French / NFS / Full Workstation / GUI Install
Comment 7 Ngo Than 2001-10-19 17:04:31 EDT
please update qt-2.3.1-7 in dist-7.2-ia64. it should fix it.

Note You need to log in before you can comment on or make changes to this bug.