This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 535236 - (RHQ-1954) update group definition expression builder to support new syntax to be released in v1.2
update group definition expression builder to support new syntax to be releas...
Status: CLOSED NEXTRELEASE
Product: RHQ Project
Classification: Other
Component: Core UI (Show other bugs)
unspecified
All All
medium Severity medium (vote)
: ---
: ---
Assigned To: Joseph Marques
Jeff Weiss
http://jira.rhq-project.org/browse/RH...
: Improvement
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-08 14:42 EDT by Joseph Marques
Modified: 2014-11-09 17:49 EST (History)
1 user (show)

See Also:
Fixed In Version: 1.2
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Joseph Marques 2009-04-08 14:42:00 EDT
here are the jiras that changed the supports group definition syntax since the last release:

http://jira.rhq-project.org/browse/RHQ-461 (support for ".child" sub context)
http://jira.rhq-project.org/browse/RHQ-1309 (filtering on unset/null properties)
http://jira.rhq-project.org/browse/RHQ-965 (support for ".availability" for any resource/child/parent/grandparent context)
Comment 1 Joseph Marques 2009-04-08 15:47:28 EDT
rev3650 - enhance the group definition expression builder to support the new syntax elements added in the 1.1->1.2 tmeframe; 
Comment 2 Joseph Marques 2009-04-13 09:50:08 EDT
".child" will be at the same level as "resource" "parent" "grandparent"
unset/null will be a checkbox visible on the expression builder
".availability" will be at the same level as "id" "name" "version"
Comment 3 Jeff Weiss 2009-04-13 09:58:00 EDT
Tested, rev3663.  Was able to build the expressions listed in the 3 jiras above using the expression builder.  Note that some of them require two separate expressions - you build one, click "Add expression" and then do another and add it. 
Comment 4 Red Hat Bugzilla 2009-11-10 15:50:13 EST
This bug was previously known as http://jira.rhq-project.org/browse/RHQ-1954

Note You need to log in before you can comment on or make changes to this bug.