Bug 535293 - (RHQ-2003) do not reload tree data each time the context menu is opened
do not reload tree data each time the context menu is opened
Status: CLOSED NEXTRELEASE
Product: RHQ Project
Classification: Other
Component: Core UI (Show other bugs)
unspecified
All All
high Severity medium (vote)
: ---
: ---
Assigned To: Joseph Marques
Jeff Weiss
http://jira.rhq-project.org/browse/RH...
: Improvement
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-22 10:31 EDT by Joseph Marques
Modified: 2014-11-09 17:49 EST (History)
1 user (show)

See Also:
Fixed In Version: 1.2
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Joseph Marques 2009-04-22 10:31:00 EDT
this is important to fix because the tree could be rather expensive to load - both in the resource and group view.
Comment 1 Joseph Marques 2009-04-22 10:31:30 EDT
rev3821 - performance: only load the resource/group nav trees once per page, i.e. context menu loads/reloads no longer cause the tree to re-query the DB for resources or the cost of rebuilding the in-memory tree
Comment 2 Jeff Weiss 2009-04-23 19:26:18 EDT
Seems faster to me.  rev3849
Comment 3 Red Hat Bugzilla 2009-11-10 15:55:52 EST
This bug was previously known as http://jira.rhq-project.org/browse/RHQ-2003

Note You need to log in before you can comment on or make changes to this bug.