Bug 53535 - configure doesn't remember extra directories
Summary: configure doesn't remember extra directories
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: rpm   
(Show other bugs)
Version: 1.0
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Paul Nasrat
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-09-11 01:00 UTC by SL Baur
Modified: 2007-04-18 16:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-06-07 19:43:25 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch (662 bytes, patch)
2001-09-11 16:40 UTC, Jeff Johnson
no flags Details | Diff

Description SL Baur 2001-09-11 01:00:07 UTC
Description of Problem:
configure doesn't remember extra directories to search for.
If bzlib.h and zlib.h are not installed in system directories
(as they won't be on a non-Linux system), they won't be found.
The fix is to add INCPATH to $ac_cpp.  A proposed patch is
attached (which also removes the hardcoding of /usr/local.

Version-Release number of selected component (if applicable):
4.0.3/CVS

How Reproducible:


Steps to Reproduce:
1. 
2. 
3. 

Actual Results:


Expected Results:


Additional Information:

Comment 1 Jeff Johnson 2001-09-11 16:40:10 UTC
Created attachment 31616 [details]
Patch

Comment 2 Paul Nasrat 2005-06-07 19:43:25 UTC
Looks like fixed in configure.ac on rpm 4.4.x.  Please reopen if still an issue
for you.


Note You need to log in before you can comment on or make changes to this bug.