This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 535398 - (RHQ-2099) be able to customize the launcher scripts' memory settings but leave the rest of the defaults [NEEDINFO]
be able to customize the launcher scripts' memory settings but leave the rest...
Status: CLOSED WONTFIX
Product: RHQ Project
Classification: Other
Component: Launch Scripts (Show other bugs)
unspecified
All All
high Severity medium (vote)
: ---
: ---
Assigned To: John Mazzitelli
http://jira.rhq-project.org/browse/RH...
: FutureFeature, Improvement
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-20 09:53 EDT by John Mazzitelli
Modified: 2014-05-05 16:53 EDT (History)
2 users (show)

See Also:
Fixed In Version: 1.4
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-05-05 16:53:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
cwelton: needinfo? (ccrouch)


Attachments (Terms of Use)

  None (edit)
Description John Mazzitelli 2009-05-20 09:53:00 EDT
Today, if you want to increase the memory settings (-Xmx, -Xms) you need to use RHQ_SERVER_JAVA_OPTS and RHQ_AGENT_JAVA_OPTS. But this means you need to reset all the other defaults since you are completely overriding the opts.

Since memory settings are more common to want to change than the other things (like the log directory for the server), let's create a new RHQ_SERVER_MEMORY_JAVA_OPTS that lets you override those but keep the other defaults. Same for RHQ_AGENT_MEMORY_JAVA_OPTS to make it consistent for the agent as it is with the server.
Comment 1 Ian Springer 2009-06-08 12:59:53 EDT
We might want to consider further splitting it out and having separate env vars for heap and permgen, e.g.:

RHQ_SERVER_INITIAL_HEAP_SIZE
RHQ_SERVER_MAX_HEAP_SIZE
RHQ_SERVER_INITIAL_PERMGEN_SIZE
RHQ_SERVER_MAX_PERMGEN_SIZE

or:

RHQ_SERVER_HEAP_SIZE_OPTS
RHQ_SERVER_PERMGEN_SIZE_OPTS

Otherwise, users could easily neglect to specify permgen setting, e.g.:

RHQ_SERVER_MEMORY_JAVA_OPTS=-Xms2048m -Xmx2048m

and end up with the JVM max permgen default of 64MB, which is too low for the JON Server, which needs a minimum of around 128MB.
Comment 2 Charles Crouch 2009-06-08 13:06:35 EDT
I dont like the sound of RHQ_SERVER_*special_property*_JAVA_OPTS. We should have some sort of .env file the server sources in order to pick up its JAVA_OPTS. The people can override this easily:
either
a) just edit the .env directly to add/change the options
or
b) override the value in the .env file by specifying an environment variable. This is easy to do because the user just copies the current value of the property from the .env file, tweaks it and specifies the new value as an env. var.
Comment 3 Charles Crouch 2009-06-08 13:07:35 EDT
Setting this to critical since its impacting customers running 1.2, e.g. case 295891
Comment 4 John Mazzitelli 2009-06-08 13:12:40 EDT
We need to NOT expose INITIAL heap. In fact I say we just have "RHQ_AGENT_HEAP_SIZE" and we automatically set the initial and max to that value. Greg and Charles can tell you why :)  Customer was fine starting the server, but once it needed to process alot of agents, heap grew and the max was too much for the memory the box had. This kind of problem would have been detected much early on if initial and max were the same. 
Comment 5 John Mazzitelli 2009-06-08 13:14:49 EDT
Sorry - I mean RHQ_SERVER_HEAPSIZE (not agent).
Comment 6 Charles Crouch 2009-09-01 10:52:31 EDT
Moving features/improvements to 1.4
Comment 7 Red Hat Bugzilla 2009-11-10 15:57:45 EST
This bug was previously known as http://jira.rhq-project.org/browse/RHQ-2099
Comment 8 wes hayutin 2010-02-16 12:09:13 EST
mass add of key word FutureFeature to help track
Comment 9 Corey Welton 2010-08-25 12:14:59 EDT
Charles and Mazz, what do we want to do here?
Comment 10 John Mazzitelli 2010-08-25 12:19:08 EDT
this is low priority/severity at minimum. I'm not too excited about this one - wouldn't hurt my feelings if we just closed this. I don't think its very important.

Note You need to log in before you can comment on or make changes to this bug.