Bug 535452 - (RHQ-2146) be able to disable the yum server in the platform plugin but still do rpm discovery
be able to disable the yum server in the platform plugin but still do rpm dis...
Status: CLOSED NEXTRELEASE
Product: RHQ Project
Classification: Other
Component: Plugins (Show other bugs)
unspecified
All All
medium Severity medium (vote)
: ---
: ---
Assigned To: John Mazzitelli
Jeff Weiss
http://jira.rhq-project.org/browse/RH...
: Improvement
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-11 16:12 EDT by John Mazzitelli
Modified: 2014-11-09 17:49 EST (History)
1 user (show)

See Also:
Fixed In Version: 1.3
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Mazzitelli 2009-06-11 16:12:00 EDT

    
Comment 1 John Mazzitelli 2009-06-11 17:39:59 EDT
svn rev4074,4076,4077 are all related.. had to fix some itty-bitty things while testing
Comment 2 Jeff Weiss 2009-06-29 11:17:35 EDT
How do I test this?  The yum server appears disabled by default.  What is 'rpm discovery'?
Comment 3 John Mazzitelli 2009-06-29 12:18:45 EDT
"rpm discovery" is when the linux platform plugin scans what software is installed on the box (it does this by asking yum for a  list of installed packages).  If this rpm discovery is enabled, after a few minutes of starting up a new agent, you will see your platform's Content tab show all the software that is installed on the box.

I've separated this feature from the ability to perform yum updates through Jopr and our content source plugins. Now, you can do rpm discovery even if you don't want the linux plugin starting up an internal yum server (which is required to support yum updates).

There are two plugin configuration properties in the linux platform resources that are relevent here, they are in the "Content" configuration group. Go to inventory>connection subtab and see these (this is from the descriptor .xml):

      <plugin-configuration>
         <c:group name="Content">
            <c:description>Settings to support content/package functionality</c:description>
            <c:simple-property
                  name="enableContentDiscovery" 
                  default="false"
                  required="true" 
                  type="boolean"
                  description="If true, attempts will be made to discover installed packages on this platform">
            </c:simple-property>
            <c:simple-property
                  name="enableInternalYumServer" 
                  default="false"
                  required="true" 
                  type="boolean"
                  description="If true, an internal yum server will be started in order to process yum content requests made on the local machine.">
            </c:simple-property>

If you set enableContentDiscovery=true and enableInternalYumServer=false, you will see be able to perform rpm discovery but you will not have a internal yum server running in the agent (you can test that you aren't by "netstat" and looking for something running on the "yumPort" (yumPort is another property in this Content group of plugin configuration - you will see it on this same UI page).

If you set enableInternalYumServer=true and enableContentDiscovery=false, the opposite will occur. netstat will show you something listening on the yumPort but you will not perform rpm discovery.
Comment 4 Jeff Weiss 2009-08-04 09:37:12 EDT
The two properties are in the connection props page.  Enabling the Content Discovery doesn't do anything though, i suspect because this is a jopr build and it doesn't have the right plugins.  Opened separate jopr jira JOPR-345 to cover that.  rev4650
Comment 5 Red Hat Bugzilla 2009-11-10 15:58:45 EST
This bug was previously known as http://jira.rhq-project.org/browse/RHQ-2146

Note You need to log in before you can comment on or make changes to this bug.