Bug 53550 - Installer crashes when upgrading from 7.0
Installer crashes when upgrading from 7.0
Status: CLOSED DUPLICATE of bug 37099
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.1
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Brent Fox
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-09-11 08:22 EDT by Need Real Name
Modified: 2007-04-18 12:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-09-12 11:46:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
file generated by error report on Linux 7.0 machine (10.09 KB, text/plain)
2001-09-11 08:23 EDT, Need Real Name
no flags Details

  None (edit)
Description Need Real Name 2001-09-11 08:22:51 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 4.0)

Description of problem:
The installer crashes after searching for packages to upgrade, or if swap 
file not initialised just at the end of the initialisation process.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Boot from seawolf i386 disc 1
2.Choose upgrade installation
3.
	

Actual Results:  The system produces an error message with the option to 
save the message to disk and restart the computer. The error is 
unrecoverable.

Expected Results:  OS should have gone through upgrade process.

Additional info:

Traceback (innermost last):
  File "/usr/bin/anaconda", line 520, in ?
    intf.run(todo, test = test)
  File "/var/tmp/anaconda-7.1//usr/lib/anaconda/gui.py", line 391, in run
    self.icw.run ()
  File "/var/tmp/anaconda-7.1//usr/lib/anaconda/gui.py", line 879, in run
    mainloop ()
  File "/usr/lib/python1.5/site-packages/gtk.py", line 2554, in mainloop
    _gtk.gtk_main()
  File "/usr/lib/python1.5/site-packages/gtk.py", line 125, in __call__
    ret = apply(self.func, a)
  File "/var/tmp/anaconda-7.1//usr/lib/anaconda/gui.py", line 481, in 
nextClicked
    next = self.currentScreen.getNext ()
  File "/var/tmp/anaconda-7.1//usr/lib/anaconda/iw/upgrade_swap_gui.py", 
line 78, in getNext
    self.todo.upgradeFindPackages()
  File "/var/tmp/anaconda-7.1//usr/lib/anaconda/todo.py", line 1240, in 
upgradeFindPackages
    iutil.rmrf (self.instPath + "/var/lib/anaconda-rebuilddb"
  File "/var/tmp/anaconda-7.1//usr/lib/anaconda/iutil.py", line 294, in 
rmrf
    files = os.listdir (path)
OSError: [Errno 2] No such file or directory

Local variables in innermost frame:
path: /mnt/sysimage/var/lib/anaconda-rebuilddb1000207141
Comment 1 Need Real Name 2001-09-11 08:23:47 EDT
Created attachment 31596 [details]
file generated by error report on Linux 7.0 machine
Comment 2 Matt Wilson 2001-09-12 11:46:43 EDT
looks like you had some error when rebuilding the rpm database.  Boot back into
your 7.0 system, run rpm --rebuilddb, then try the upgrade again.
Comment 3 Matt Wilson 2001-09-12 11:51:05 EDT

*** This bug has been marked as a duplicate of 37099 ***

Note You need to log in before you can comment on or make changes to this bug.