Bug 535705 - (RHQ-2373) refactor logging around agent backfiller / suspect agent job
refactor logging around agent backfiller / suspect agent job
Status: CLOSED NEXTRELEASE
Product: RHQ Project
Classification: Other
Component: Monitoring (Show other bugs)
unspecified
All All
high Severity medium (vote)
: ---
: ---
Assigned To: Joseph Marques
Jeff Weiss
http://jira.rhq-project.org/browse/RH...
: Improvement
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-08-20 11:24 EDT by Joseph Marques
Modified: 2014-11-09 17:49 EST (History)
1 user (show)

See Also:
Fixed In Version: 1.3
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Joseph Marques 2009-08-20 11:24:00 EDT
in a large inventory, you might see hundreds and hundreds of "have not heard from agent...will be backfilled since we suspect it is down."  this message is unhelpful for two reasons:

1) it's printed when the agent is already backfilled, so we don't know whether it's actually BEING backfilled when we see the message
2) we print this message periodically (comments say ~4 times over each 6 hr period), but again because of #1 this is not helpful

so, we want to print this message once and only once when that particular agent is being backfilled...and we want it at info level so we absolutely don't miss it.
Comment 1 Joseph Marques 2009-08-20 11:26:54 EDT
rev4968 - refactor logging for agent backfiller / suspect agent job; 
Comment 2 Joseph Marques 2009-08-28 10:29:05 EDT
reopening because fix is only in perf branch, but it need to be in trunk too.
Comment 3 Jeff Weiss 2009-08-28 10:33:40 EDT
<joseph> so instead of infinite number of WARN messages, it's just one INFO message
Comment 4 Joseph Marques 2009-09-03 03:32:46 EDT
rev5082 - refactor logging for agent backfiller / suspect agent job so that it only prints one INFO message when an agent is actually being backfilled, instead of flooding the logs until that agent comes back up; 
Comment 5 Jeff Weiss 2009-09-09 12:50:30 EDT
Fixed, rev5122, linux/postgres. 

2009-09-09 12:41:02,111 INFO  [org.rhq.enterprise.server.core.AgentManagerBean] Have not heard from agent [jweiss-rhel1.usersys.redhat.com] since [Wed Sep 09 12:25:50 EDT 2009]. Will be backfilled since we suspect it is down


This appeared about 20 min after i killed the agent.  Just one message.
Comment 6 Red Hat Bugzilla 2009-11-10 16:03:08 EST
This bug was previously known as http://jira.rhq-project.org/browse/RHQ-2373
Comment 7 wes hayutin 2010-02-16 16:07:49 EST
Mass move to component= Monitoring

Note You need to log in before you can comment on or make changes to this bug.