Bug 535952 - (RHQ-353) Implement resource auto-subscription to channels
Implement resource auto-subscription to channels
Status: CLOSED WONTFIX
Product: RHQ Project
Classification: Other
Component: Content (Show other bugs)
1.0.1
All All
medium Severity medium (vote)
: ---
: ---
Assigned To: RHQ Project Maintainer
http://jira.rhq-project.org/browse/RH...
: FutureFeature
: RHQ-523 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-21 13:45 EDT by Jason Dobies
Modified: 2014-05-12 15:30 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-05-12 15:30:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jason Dobies 2008-04-21 13:45:00 EDT
One of the things discussed during the design of the content subsystem was the ability to have resources automatically subscribe to channels to prevent users in large environments from having to manually maintain subscriptions. The current admin UI for content provides reasonably good filtering to allow a user to quickly subscribe a number of resources, however this isn't automatic.

There are a few ways this can be achieved and this JIRA will provide that discussion before starting work on it. One idea is to leverage similar concepts as in the group definition ability (the conditions and recalculate ideas). Another might be to check the types of packages present in a channel and then automatically determine resources against which they can be installed. In either case, there is also the possibility of using a widget similar to resource import to accept/deny the automatic subscriptions determined by whatever algorithm we use.
Comment 1 Red Hat Bugzilla 2009-11-10 16:07:34 EST
This bug was previously known as http://jira.rhq-project.org/browse/RHQ-353
Comment 2 David Lawrence 2009-11-11 12:28:00 EST
*** Bug 536141 has been marked as a duplicate of this bug. ***
Comment 3 Corey Welton 2010-10-06 23:27:52 EDT
Triaged 5-Oct

Note You need to log in before you can comment on or make changes to this bug.