Bug 535957 - (RHQ-358) upgrade to RichFaces 3.2.x
upgrade to RichFaces 3.2.x
Status: CLOSED NOTABUG
Product: RHQ Project
Classification: Other
Component: Core UI (Show other bugs)
0.1
All All
medium Severity medium (vote)
: ---
: ---
Assigned To: Ian Springer
http://jira.rhq-project.org/browse/RH...
: Task
Depends On:
Blocks: RHQ-619
  Show dependency treegraph
 
Reported: 2008-04-21 17:49 EDT by Ian Springer
Modified: 2013-08-05 20:34 EDT (History)
1 user (show)

See Also:
Fixed In Version: 1.2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Ian Springer 2008-04-21 17:49:00 EDT
There are tons of bug fixes in this release, as well as a number of features we could take advantage of (see http://jira.jboss.com/jira/secure/ReleaseNote.jspa?projectId=12310341&styleName=Html&version=12311320). Here are a few examples of features I think we could leverage:

- DataTable sorting and filtering - http://jira.jboss.com/jira/browse/RF-1736
- File upload component - http://jira.jboss.com/jira/browse/RF-238
- Combo box component - http://jira.jboss.com/jira/browse/RF-984
- Progress bar component - http://jira.jboss.com/jira/browse/RF-1686
- skinnable buttons and input fields - http://jira.jboss.com/jira/browse/RF-402
Comment 1 Charles Crouch 2008-04-22 10:55:15 EDT
3.2.0.SR1 is out now with more fixes
Comment 3 Ian Springer 2008-07-10 20:09:28 EDT
Done - r1084.

I smoke-tested the GUI, and everything seems to still work, but it will get more thorough testing as the rest of the dev team and QA pound on it over the next few weeks.
Comment 4 Charles Crouch 2008-07-10 20:51:24 EDT
"upgraded RichFaces from 3.1.3.GA to 3.2.1.GA"
Comment 5 Ian Springer 2008-07-17 09:06:04 EDT
Downgraded from 3.2.1.GA to 3.2.0.GA, due to a couple bugs Heiko found in 3.2.1.GA  (one only on MacOS and one on both MacOS and Linux) - r1110. 

Heiko, if/when you create RF JIRA issues for the two bugs, please link them off this case.
Comment 6 Heiko W. Rupp 2008-07-17 10:52:38 EDT
VM-Crash: https://jira.jboss.org/jira/browse/RF-3944
Property-save-issue: https://jira.jboss.org/jira/browse/RF-3945
Comment 7 Greg Hinkle 2008-10-16 12:09:45 EDT
I understand this isn't actually complete
Comment 8 Ian Springer 2008-10-17 14:12:47 EDT
Well, it sort of is. We ended up moving up to 3.2.0.GA. We decided not to go to 3.2.1.GA due to the issues Heiko was seeing on Mac.
Comment 9 Ian Springer 2008-12-23 10:25:20 EST
See also: http://www.jboss.org/community/docs/DOC-12902 (Whats new in 3.2.2SR1)
Comment 10 Joseph Marques 2009-02-14 10:05:01 EST
we've been at 3.3.0.GA for a few weeks now, and the app has gotten a sufficient exercising.  several bugs have shaken out now due to QAs growing regression automation.
Comment 11 Red Hat Bugzilla 2009-11-10 16:07:40 EST
This bug was previously known as http://jira.rhq-project.org/browse/RHQ-358

Note You need to log in before you can comment on or make changes to this bug.