This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 535971 - (RHQ-370) support better formatting for metrics with epoch-millis units
support better formatting for metrics with epoch-millis units
Status: CLOSED WONTFIX
Product: RHQ Project
Classification: Other
Component: Monitoring (Show other bugs)
1.0
All All
medium Severity medium (vote)
: ---
: ---
Assigned To: RHQ Project Maintainer
http://jira.rhq-project.org/browse/RH...
: FutureFeature, Improvement
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-24 06:49 EDT by Jaroslaw Kijanowski
Modified: 2014-05-12 15:34 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-05-12 15:34:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Screenshot_2.png (26.24 KB, image/png)
2008-06-11 09:37 EDT, Heiko W. Rupp
no flags Details

  None (edit)
Description Jaroslaw Kijanowski 2008-04-24 06:49:00 EDT
look at HibernateSessionFactory StartTime metric:

StartTime in the jmx-console is
1209032489124
but the metrics show
1,209,000,000,000.0
Comment 1 Heiko W. Rupp 2008-06-11 09:37:57 EDT
I think the displayed value is correct, but the formatting of the epoch_millis a little confusing.

What bothers me more is that this constant value (actually the start time stays constant as long as Hibernate / JBossAS is running) is a metric and no trait.
Comment 2 Red Hat Bugzilla 2009-11-10 16:07:55 EST
This bug was previously known as http://jira.rhq-project.org/browse/RHQ-370
Imported an attachment (id=368817)
Comment 3 wes hayutin 2010-02-16 16:09:14 EST
Mass move to component = Monitoring
Comment 5 Joseph Marques 2010-12-20 17:19:31 EST
currently, we don't support formatting Traits because they are string values and don't have associated units.  heiko, can you ballpark an estimate for how long it would take to enable supports units for traits (plugin descriptor [making sure it's forward compatible], parsing, db upgrade, metadata upgrade, units scaling, & ui display.
Comment 6 Heiko W. Rupp 2011-01-05 08:47:28 EST
Units are already in the plugin descriptor, parsed and stored in the DB.

Getting the unit and formatting it would need a change in the query for traits to include the units from the definition and then if units!=0 to call the appropriate formatter like for numeric data. 
In addition the return type of some methods need to be changed (possibly to a composite).
CLI probably also needs an update.
I'd say: without CLI around 2 days. CLI at least one more day.

Note You need to log in before you can comment on or make changes to this bug.