This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 535988 - (RHQ-386) decrease time needed for measurement merge
decrease time needed for measurement merge
Status: CLOSED NOTABUG
Product: RHQ Project
Classification: Other
Component: Monitoring (Show other bugs)
0.1
All All
medium Severity medium (vote)
: ---
: ---
Assigned To: Joseph Marques
http://jira.rhq-project.org/browse/RH...
: Improvement
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-28 19:12 EDT by Joseph Marques
Modified: 2010-02-16 16:09 EST (History)
0 users

See Also:
Fixed In Version: 1.3
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Joseph Marques 2008-04-28 19:12:00 EDT
the data below shows that it takes a terribly long time to merge relative little data.  notice that it takes nearly the same amount of time to merge 4 as it does 562.

2008-04-28 08:22:06,697 INFO  [org.rhq.enterprise.server.measurement.MeasurementServerServiceImpl] Performance: measurement merge [87] timing (24908)ms
2008-04-28 08:22:06,697 INFO  [org.rhq.enterprise.server.measurement.MeasurementServerServiceImpl] Performance: measurement merge [76] timing (24963)ms
2008-04-28 08:22:06,697 INFO  [org.rhq.enterprise.server.measurement.MeasurementServerServiceImpl] Performance: measurement merge [33] timing (24890)ms
2008-04-28 08:22:06,697 INFO  [org.rhq.enterprise.server.measurement.MeasurementServerServiceImpl] Performance: measurement merge [28] timing (24954)ms
2008-04-28 08:22:06,697 INFO  [org.rhq.enterprise.server.measurement.MeasurementServerServiceImpl] Performance: measurement merge [400] timing (24955)ms
2008-04-28 08:22:06,697 INFO  [org.rhq.enterprise.server.measurement.MeasurementServerServiceImpl] Performance: measurement merge [474] timing (24958)ms
2008-04-28 08:22:06,697 INFO  [org.rhq.enterprise.server.measurement.MeasurementServerServiceImpl] Performance: measurement merge [426] timing (24903)ms
2008-04-28 08:22:06,698 INFO  [org.rhq.enterprise.server.measurement.MeasurementServerServiceImpl] Performance: measurement merge [32] timing (24912)ms
2008-04-28 08:22:06,697 INFO  [org.rhq.enterprise.server.measurement.MeasurementServerServiceImpl] Performance: measurement merge [14] timing (24914)ms
2008-04-28 08:22:06,699 INFO  [org.rhq.enterprise.server.measurement.MeasurementServerServiceImpl] Performance: measurement merge [289] timing (24903)ms
2008-04-28 08:22:06,698 INFO  [org.rhq.enterprise.server.measurement.MeasurementServerServiceImpl] Performance: measurement merge [419] timing (24953)ms
2008-04-28 08:22:06,702 INFO  [org.rhq.enterprise.server.measurement.MeasurementServerServiceImpl] Performance: measurement merge [8] timing (24760)ms
2008-04-28 08:22:06,703 INFO  [org.rhq.enterprise.server.measurement.MeasurementServerServiceImpl] Performance: measurement merge [5] timing (24764)ms
2008-04-28 08:22:06,705 INFO  [org.rhq.enterprise.server.measurement.MeasurementServerServiceImpl] Performance: measurement merge [8] timing (24766)ms
2008-04-28 08:22:06,705 INFO  [org.rhq.enterprise.server.measurement.MeasurementServerServiceImpl] Performance: measurement merge [414] timing (24920)ms
2008-04-28 08:22:06,706 INFO  [org.rhq.enterprise.server.measurement.MeasurementServerServiceImpl] Performance: measurement merge [562] timing (24918)ms
2008-04-28 08:22:06,712 INFO  [org.rhq.enterprise.server.measurement.MeasurementServerServiceImpl] Performance: measurement merge [4] timing (24654)ms
2008-04-28 08:22:06,714 INFO  [org.rhq.enterprise.server.measurement.MeasurementServerServiceImpl] Performance: measurement merge [5] timing (24658)ms
2008-04-28 08:22:06,714 INFO  [org.rhq.enterprise.server.measurement.MeasurementServerServiceImpl] Performance: measurement merge [8] timing (24771)ms
2008-04-28 08:22:06,715 INFO  [org.rhq.enterprise.server.measurement.MeasurementServerServiceImpl] Performance: measurement merge [5] timing (24659)ms
2008-04-28 08:22:06,715 INFO  [org.rhq.enterprise.server.measurement.MeasurementServerServiceImpl] Performance: measurement merge [8] timing (24640)ms
2008-04-28 08:22:06,716 INFO  [org.rhq.enterprise.server.measurement.MeasurementServerServiceImpl] Performance: measurement merge [8] timing (24768)ms
2008-04-28 08:22:06,715 INFO  [org.rhq.enterprise.server.measurement.MeasurementServerServiceImpl] Performance: measurement merge [8] timing (24658)ms
2008-04-28 08:22:06,717 INFO  [org.rhq.enterprise.server.measurement.MeasurementServerServiceImpl] Performance: measurement merge [5] timing (24658)ms
2008-04-28 08:22:06,715 INFO  [org.rhq.enterprise.server.measurement.MeasurementServerServiceImpl] Performance: measurement merge [15] timing (24771)ms
2008-04-28 08:22:06,717 INFO  [org.rhq.enterprise.server.measurement.MeasurementServerServiceImpl] Performance: measurement merge [5] timing (24661)ms
2008-04-28 08:22:06,718 INFO  [org.rhq.enterprise.server.measurement.MeasurementServerServiceImpl] Performance: measurement merge [8] timing (24774)ms
2008-04-28 08:22:06,714 INFO  [org.rhq.enterprise.server.measurement.MeasurementServerServiceImpl] Performance: measurement merge [8] timing (24656)ms
2008-04-28 08:22:06,714 INFO  [org.rhq.enterprise.server.measurement.MeasurementServerServiceImpl] Performance: measurement merge [50] timing (24658)ms
2008-04-28 08:22:06,722 INFO  [org.rhq.enterprise.server.measurement.MeasurementServerServiceImpl] Performance: measurement merge [24] timing (24777)ms
2008-04-28 08:22:06,724 INFO  [org.rhq.enterprise.server.measurement.MeasurementServerServiceImpl] Performance: measurement merge [8] timing (24663)ms
2008-04-28 08:22:06,724 INFO  [org.rhq.enterprise.server.measurement.MeasurementServerServiceImpl] Performance: measurement merge [8] timing (24401)ms
2008-04-28 08:22:06,724 INFO  [org.rhq.enterprise.server.measurement.MeasurementServerServiceImpl] Performance: measurement merge [5] timing (24078)ms
2008-04-28 08:22:06,725 INFO  [org.rhq.enterprise.server.measurement.MeasurementServerServiceImpl] Performance: measurement merge [5] timing (24399)ms
2008-04-28 08:22:06,727 INFO  [org.rhq.enterprise.server.measurement.MeasurementServerServiceImpl] Performance: measurement merge [43] timing (24669)ms
2008-04-28 08:22:06,740 INFO  [org.rhq.enterprise.server.measurement.MeasurementServerServiceImpl] Performance: measurement merge [426] timing (24681)ms
2008-04-28 08:22:07,420 INFO  [org.rhq.enterprise.server.measurement.MeasurementServerServiceImpl] Performance: measurement merge [60] timing (25364)ms
2008-04-28 08:22:07,638 INFO  [org.rhq.enterprise.server.measurement.MeasurementServerServiceImpl] Performance: measurement merge [55] timing (25694)ms
Comment 1 Greg Hinkle 2008-05-22 00:18:45 EDT
This was pretty well optimized and I haven't seen results like those you see except when something was blocking database connections (which i suspect was the case here) since they all kinda finished at the same time. 

I haven't seen the connection usage problems since the alert fixes so this probably isn't happening anymore. Joe have you seen this since those fixes? Assigning to you for comment... close if you haven't seen this recently.
Comment 2 Joseph Marques 2008-07-02 06:31:52 EDT
won't have enough time for another round of performance testing until after 1.1.0 is released.  pushing to 2.0 time frame.
Comment 3 Joseph Marques 2008-07-20 17:00:26 EDT
on second though, going to return this since i'm not a fan of chasing ghosts.  this was seen a long time ago, and we can always reopen if we see this issue again in the future.
Comment 4 Red Hat Bugzilla 2009-11-10 16:08:14 EST
This bug was previously known as http://jira.rhq-project.org/browse/RHQ-386
Comment 5 wes hayutin 2010-02-16 16:09:55 EST
Mass move to component = Monitoring

Note You need to log in before you can comment on or make changes to this bug.