Bug 536037 - (RHQ-42) Resource/Group Name links should default to Monitoring tab. Two caveats in description.
Resource/Group Name links should default to Monitoring tab. Two caveats in de...
Status: CLOSED WONTFIX
Product: RHQ Project
Classification: Other
Component: Core UI (Show other bugs)
0.1
All All
medium Severity medium (vote)
: ---
: ---
Assigned To: RHQ Project Maintainer
http://jira.rhq-project.org/browse/RH...
:
: RHQ-39 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-06 11:28 EST by Mark Spritzler
Modified: 2013-12-07 10:40 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-07 10:40:16 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Mark Spritzler 2008-03-06 11:28:00 EST
There are some links, like breadcrumbs as example where the Resource/Group name links to the Inventory page.

So after discussing, here are the rules for all Resource/Group Name links throughout the UI
1. Go to the Monitoring Tab
2. If Monitoring is not enabled from license, then there is already code that will take them to the Inventory page.
3. From Breadcrumbs if the user is on a different tab for that resource, it stays on that page. Otherwise go to Monitoring.

The discussion finale

(8:15:17 AM) mspritz: Anyway, I think everyone agrees that all resource/group name links should take you to the Monitoring page, except your suggestion that breadcrumbs stay on the same page, if they are on a different page for that resource. And if monitoring is not enabled, then go to Inventory.
(8:15:17 AM) mspritz: How is that? 
(8:16:09 AM) ghinkle: well put
Comment 1 Greg Hinkle 2008-05-22 00:19:41 EDT
This one bugs me... let's see if it fits in 1.0.1.
Comment 2 Joseph Marques 2008-07-02 07:15:27 EDT
didn't fit into 1.0.1, but let's see if it fit into 1.1.0 instead.
Comment 3 Red Hat Bugzilla 2009-11-10 16:09:06 EST
This bug was previously known as http://jira.rhq-project.org/browse/RHQ-42
This bug is duplicated by RHQ-39
Comment 4 David Lawrence 2009-11-11 12:25:42 EST
*** Bug 536003 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.