Bug 536175 - (RHQ-553) Manually add platform services
Manually add platform services
Status: CLOSED WONTFIX
Product: RHQ Project
Classification: Other
Component: No Component (Show other bugs)
1.0
All All
low Severity medium (vote)
: ---
: ---
Assigned To: RHQ Project Maintainer
http://jira.rhq-project.org/browse/RH...
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-06-09 18:32 EDT by Charles Crouch
Modified: 2015-02-01 18:25 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-05-13 12:27:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Charles Crouch 2008-06-09 18:32:00 EDT
Maybe I'm missing this, but on the Inventory tab for the platform I don't see a way to manually add platform services, only Server e.g. Apache, JBoss. It might be nice to be able to add platform services such as file systems that we're missed/not recognized in the autodiscovery process, cf. the long filesystem name in RHQ-481
Comment 1 Joseph Marques 2008-07-19 19:41:28 EDT
why does a user have to specify that manual addition is allowed?  what are the dangers of automatically supporting manual addition for all resources types?
Comment 2 Greg Hinkle 2008-07-30 09:54:42 EDT
Are we saying that those services don't have "manually add" capability declared? or are we saying that the feature doesn't work for platform services?

We added the Manual Add declaration on purpose joseph. Most of our resources do not support manual add and this was a way to keep the user from going through the process just to get an error.
Comment 3 Joseph Marques 2008-07-31 08:56:53 EDT
i guess i don't quite understand the restrictions around manual add.  from a non-plugin developer perspective, it looks like the only thing i would need to do for ANY resourceType would be to fill in the PluginConfiguration / connection property information (and maybe a unique resource key), and I can start managing something that RHQ didn't auto-discovery.  is it sometimes more complicated than that, and that's why this is restricted by default?
Comment 4 Greg Hinkle 2008-07-31 10:40:26 EDT
Yea, that's the biggest difference between the old model and the new model. Only the plugin can translate the plugin config into a valid resourceKey so we go through the standard Discovery component. We've talked about separating this interface method to make it a bit more obvious about how to provide manual inventory support.
Comment 5 Red Hat Bugzilla 2009-11-10 16:11:46 EST
This bug was previously known as http://jira.rhq-project.org/browse/RHQ-553
Comment 6 Jay Shaughnessy 2014-05-13 12:27:02 EDT
No changes planned for the current declarative approach.

Note You need to log in before you can comment on or make changes to this bug.