Bug 53619 - up2date library error
up2date library error
Product: Red Hat Linux
Classification: Retired
Component: up2date (Show other bugs)
i586 Linux
medium Severity medium
: ---
: ---
Assigned To: Adrian Likins
Jay Turner
Depends On:
  Show dependency treegraph
Reported: 2001-09-12 23:08 EDT by Alton Weeks
Modified: 2015-01-07 18:51 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2001-09-12 23:08:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Alton Weeks 2001-09-12 23:08:36 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.77 [en] (X11; U; Linux 2.2.16-22 i586)

Description of problem:
I recently got up2date 2.5.4 loaded on my system.  I tested it on a few
updates then I went for broke.  I loaded a number of packages.  Now when I
try to run it I receive the following error:

Traceback (innermost last):
  File "/usr/sbin/.up2date", line 16, in ?
     import up2date
  File "/usr/share/rhn/up2date/up2date.py", in line 13, in ?
     Import socket
ImpoerError: symbol __sysconf, version GLIBC_2.2 not defined in file
libc.so.6 with link time reference.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. up2date

Additional info:
Comment 1 Jay Turner 2001-09-13 08:21:40 EDT
You need the latest glibc installed.
Comment 2 Alton Weeks 2001-09-13 09:28:10 EDT
Thanks! It worked great!

Note You need to log in before you can comment on or make changes to this bug.