Bug 536191 - (RHQ-568) Disable web services
Disable web services
Status: CLOSED NEXTRELEASE
Product: RHQ Project
Classification: Other
Component: Web Services (Show other bugs)
1.0.1
All All
medium Severity medium (vote)
: ---
: ---
Assigned To: Joseph Marques
http://jira.rhq-project.org/browse/RH...
: Task
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-06-11 11:43 EDT by Jason Dobies
Modified: 2008-08-19 15:51 EDT (History)
0 users

See Also:
Fixed In Version: 1.1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jason Dobies 2008-06-11 11:43:00 EDT
Since we have no current use for them, it would greatly speed up server boot time if we removed the loading of the web services.
Comment 1 Joseph Marques 2008-07-19 19:12:01 EDT
agreed.  these can be disabled by default, and we can add an element in our documentation about how to turn them on for integrators that want to communicate with the exposed platform services.
Comment 2 Joseph Marques 2008-07-24 10:02:14 EDT
(12:04:11 PM) mspritz: FYI, if you want your JON server to startup faster, you can disable the EJB3 Webservices by going into you deploy/jbossws.sar/META-INF/jboss-service.xml and comment out the last MBean.
(12:04:11 PM) mspritz: Now you will see three other MBean not starting because of depencies like
(12:04:11 PM) mspritz: ObjectName: jboss.beans:service=JBossBeanDeployment,name='jbossws.sar#jbossws.beans'
(12:04:11 PM) mspritz: However, these are MBeans that you don't need to run JON as we are running it. It just won't deploy mazz's web services.
(12:04:42 PM) mspritz: If you need mazz's web services then don't comment that MBean out.

So basically comment out the last mbean in the deploy/jbossws.sar/META-INF/jboss-service.xml
Then
comment out mbean <bean name="WSDeployerHook_JAXWS_EJB3" at deploy\jbossws.sar\jbossws.beans\META-INF\jboss-beans.xml line 245

No web services and no errors if you do both.
Comment 3 Joseph Marques 2008-07-24 10:05:19 EDT
actually, i just tried adding ".rej" to the jbossws.sar, and it did the same thing.  going with this solution since the filesystem structure will make it clear that it is disabled without having to dive into any files to understand what to un/comment.
Comment 4 Joseph Marques 2008-07-24 14:12:48 EDT
rev1139 - add "prepare-web-services" target to the container's ant build script; 
add boolean "rhq.server.enable.web.services" property at the rhq root pom; 
pass property through to ant build script in container's pom; 
requires clean/install of the container module to take effect; 
Comment 5 Joseph Marques 2008-07-30 01:29:04 EDT
rev1145 - more resilient mechanism for disabling web services; 
Comment 6 Joseph Marques 2008-07-30 01:29:22 EDT
rev1146 - we should always run prrepare-web-services-1, and conditionally run prepare-web-services-2; 
Comment 7 Joseph Marques 2008-07-30 11:27:04 EDT
rev1147 - ok, thanks to http://jira.codehaus.org/browse/MNG-3690 i had to rename this property from "rhq.server.enable.web.services" to "rhq.server.enable.ws"
Comment 8 Red Hat Bugzilla 2009-11-10 16:12:04 EST
This bug was previously known as http://jira.rhq-project.org/browse/RHQ-568

Note You need to log in before you can comment on or make changes to this bug.