Bug 536248 - (RHQ-619) use RichFaces JSF calendar component in places where date/time must be specified in GUI
use RichFaces JSF calendar component in places where date/time must be specif...
Status: CLOSED NEXTRELEASE
Product: RHQ Project
Classification: Other
Component: Core UI (Show other bugs)
1.0.1
All All
medium Severity medium (vote)
: ---
: ---
Assigned To: Joseph Marques
Pavel Kralik
http://jira.rhq-project.org/browse/RH...
: Improvement
Depends On: RHQ-358
Blocks:
  Show dependency treegraph
 
Reported: 2008-06-24 14:47 EDT by Ian Springer
Modified: 2013-08-05 20:35 EDT (History)
2 users (show)

See Also:
Fixed In Version: 1.2
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ian Springer 2008-06-24 14:47:00 EDT
We want this for scheduling (for, say, operations) as well as the advanced page for choosing the date range for viewing metrics.

RF has calendar component now:
http://livedemo.exadel.com/richfaces-demo/richfaces/calendar.jsf?c=calendar

We should definitely think about this since it includes a way of specifing the time also. Would make scheduling operations much less error prone
Comment 1 Joseph Marques 2008-07-19 15:22:33 EDT
moving to 1.2 since RHQ-358 was rejected for 1.1 inclusion due to bugs in upstream dependency.
Comment 2 Joseph Marques 2008-12-14 14:09:13 EST
rev2370 -  use richfaces calendar for operation scheduling; 
Comment 3 Corey Welton 2008-12-18 16:23:51 EST
do we have a list of all pages featuring this component?
Comment 4 Pavel Kralik 2009-01-09 11:12:19 EST
I tested the RF calendar in this location:
Platform > Operations > NEW > Manual Autodiscovery, View Process List
I can select any datetime. When a date from the past is selected, it cannot be scheduled and an error is reported: There was an error scheduling your operation: Can not schedule operations in the past.

RHEL5.2, x86_64, PostgreSQL 8.1.11
Comment 5 Red Hat Bugzilla 2009-11-10 16:13:24 EST
This bug was previously known as http://jira.rhq-project.org/browse/RHQ-619
This bug is related to RHQ-1283
This bug relates to RHQ-1283

Note You need to log in before you can comment on or make changes to this bug.