Bug 53625 - wine startup script broken
wine startup script broken
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: wine (Show other bugs)
7.3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bernhard Rosenkraenzer
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-09-13 06:04 EDT by Michael Redinger
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-03-24 10:11:20 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael Redinger 2001-09-13 06:04:45 EDT
Description of Problem:
Changing eg. from runlevel 5 to runlevel 3, wine says that the startup
script [FAILED].
Looking at the startup script,
/sbin/modprobe ... works fine
However, the echo "..." > /proc/sys/fs/binfmt_misc/register  commands
do not work, the exit status is 1. Trying a /proc/sys/fs/binfmt_misc says
cat: register: invalid argument

Version-Release number of selected component (if applicable):
wine-20010822-1

How Reproducible:
100%

Steps to Reproduce:
1.  chkconfig wine on
2.  telinit 3
3.  telinit 5

Actual Results:
wine startup seems to fail (well, I suppose it doesn't actually as it was
already
previousely registered).

Expected Results:
Just get rid of the FAILED ... :)

Additional Information:
Hm, I don't really understand why the wine startup script is executed when
changing from 5 to 3 ...
Comment 1 Michael Redinger 2002-03-24 10:11:15 EST
The problem still exists in Hampton beta3.
Comment 2 Bernhard Rosenkraenzer 2002-03-27 09:02:12 EST
It's rerun because it doesn't support status. 
Both issues are fixed in 20020327-1. 

Note You need to log in before you can comment on or make changes to this bug.