Bug 53638 - com_err.so silliness
com_err.so silliness
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: krb5 (Show other bugs)
7.1
i386 Linux
medium Severity low
: ---
: ---
Assigned To: Nalin Dahyabhai
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-09-13 12:44 EDT by Ed Avis
Modified: 2007-04-18 12:37 EDT (History)
1 user (show)

See Also:
Fixed In Version: 1.3-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-07 16:06:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ed Avis 2001-09-13 12:44:09 EDT
Description of Problem: the library com_err.so and associated header files
has two different versions installed in RedHat 7.1.  That may be necessary.
But it is not sensible to have this library - which is depended on by 39
other packages including gnome-utils, sendmail and kde-base - provided by
the e2fsprogs-devel and krb5-devel packages.  It should be broken out into
one or two separate library packages.

This isn't actually a *bug*, it's just not the right way to do things,
having some random package like e2fsprogs-devel providing a completely
unrelated library to other packages across the system.  (There is one
report on Bugzilla that was indirectly caused by this confusion, #44953,
but that's not the main reason for fixing it.)

% for i in `locate com_err.h`; do rpm -qf $i; ls -l $i; head $i; done
e2fsprogs-devel-1.19-4
-rw-r--r--    1 root     root         1182 Apr  7 15:30
/usr/include/et/com_err.h
/*
 * Header file for common error description library.
 *
 * Copyright 1988, Student Information Processing Board of the
 * Massachusetts Institute of Technology.
 *
 * For copyright and distribution info, see the documentation supplied
 * with this package.
 */

krb5-devel-1.2.2-4
-rw-r--r--    1 root     root         2580 Mar 30 17:57
/usr/kerberos/include/com_err.h
/*
 * Header file for common error description library.
 *
 * Copyright 1988, Student Information Processing Board of the
 * Massachusetts Institute of Technology.
 *
 * Copyright 1995 by Cygnus Support.
 *
 * For copyright and distribution info, see the documentation supplied
 * with this package.

(Actually, on my system there is a third package shown, because the
packagers of openacs also included their own copy of the code.  If the
com_err library were packaged seperately they could just depend upon
that.)

It looks like the krb5-devel version is the one to use, and if possible
packages like gnome-utils, gmc and anaconda (and e2fsprogs) could be
compiled against this version.  Then there would at least be only one
copy on the system.

But more important than that is moving this code into a separate library
package where it belongs.

Sorry if this sounds like too much of a rant, that wasn't the intention.
I noticed this because I found another program that uses com_err; if I
package it up then it will sound strange to say to users: to build 
this software you must first install the totally unrelated 
package e2fsprogs-devel :-P.
Comment 1 Bill Nottingham 2006-08-07 15:45:59 EDT
Red Hat Linux is no longer supported by Red Hat, Inc. If you are still
running Red Hat Linux, you are strongly advised to upgrade to a
current Fedora Core release or Red Hat Enterprise Linux or comparable.
Some information on which option may be right for you is available at
http://www.redhat.com/rhel/migrate/redhatlinux/.

Red Hat apologizes that these issues have not been resolved yet. We do
want to make sure that no important bugs slip through the cracks.
Please check if this issue is still present in a current Fedora Core
release. If so, please change the product and version to match, and
check the box indicating that the requested information has been
provided. Note that any bug still open against Red Hat Linux on will be
closed as 'CANTFIX' on September 30, 2006. Thanks again for your help.

Note You need to log in before you can comment on or make changes to this bug.