Bug 536388 - (RHQ-742) reduce the time it takes to load/reload the alert cache
reduce the time it takes to load/reload the alert cache
Status: CLOSED NEXTRELEASE
Product: RHQ Project
Classification: Other
Component: Alerts (Show other bugs)
1.1pre
All All
urgent Severity medium (vote)
: ---
: ---
Assigned To: Joseph Marques
Jeff Weiss
http://jira.rhq-project.org/browse/RH...
: Improvement
Depends On:
Blocks: RHQ-751
  Show dependency treegraph
 
Reported: 2008-08-19 16:06 EDT by Joseph Marques
Modified: 2014-11-09 17:50 EST (History)
1 user (show)

See Also:
Fixed In Version: 1.1
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
customer had 64 platforms inventoried and used templates to create ~4K conditions and tens of thousands of enabled schedules (which creates OOB elements). database was postgres.
Last Closed:
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Joseph Marques 2008-08-19 16:06:00 EDT
customer experienced multi-minute load times, and only way this could be reduced was by cascading disabling the alert templates and slowly turning them back on.  caching loading needs to be faster.
Comment 1 Joseph Marques 2008-08-19 23:41:02 EDT
branches/RHQ_1_0_1_GA_CP : rev1261 - improve cache load time by using composites and pre-fetching all associated condition data needed at query-time;
Comment 2 Joseph Marques 2008-08-25 01:20:35 EDT
trunk (1.1.0-SNAPSHOT) : rev1275 - improve cache load time by using composites and pre-fetching all associated condition data needed at query-time;
Comment 3 Jeff Weiss 2008-09-04 12:11:14 EDT
<joseph> jweiss, 742 is well tested
<joseph> i wrote a very, very long email about the testing i did for it  ; )

I am going to close this out since we're currently not well equipped to do performance testing.
Comment 4 Red Hat Bugzilla 2009-11-10 16:16:02 EST
This bug was previously known as http://jira.rhq-project.org/browse/RHQ-742

Note You need to log in before you can comment on or make changes to this bug.