Bug 53639 - dhcp does not recognize CABLE modem
dhcp does not recognize CABLE modem
Product: Red Hat Linux
Classification: Retired
Component: dhcp (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Daniel Walsh
Depends On:
  Show dependency treegraph
Reported: 2001-09-13 13:00 EDT by Raj Selvaraj
Modified: 2007-04-18 12:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2003-08-22 15:14:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
Fixes /etc/DHCP_HOSTNAME for cable modems (747 bytes, patch)
2001-09-19 18:42 EDT, Soren Juelsgaard
no flags Details | Diff

  None (edit)
Description Raj Selvaraj 2001-09-13 13:00:54 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows NT 4.0)

Description of problem:
I installed RedHat Linux 7.1 which I downloaded from ftp.redhat.com and 
burnt it 2 CDs.  I did a custome class installation with all the 
components selected.  When I boot the computer it stops at eth0 activating 
and comes FAILED after sitting there for a long time.  I have tried to 
make the dhcp see my cable modem by using netcf and linuxconf.  Till now 
it has not worked.  

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1.Does not activate the network care eth0 at boot time

Additional info:
Comment 1 Soren Juelsgaard 2001-09-18 12:44:58 EDT
The problem is that the initscripts issues a command 
"pump -i <DEVICE> --lookup-hostname", and if you are using something like
@home they want you to specify the hostname like, eg.:
"pump -h <HOSTNAME> i- <DEVICE>", where HOSTNAME is the hostname they gave
you, and DEVICE is something like eth0.
I have made a workaround for that; a function reads the hostname from 
/etc/DHCP_HOSTNAME has been added to /etc/sysconfig/network/network-functions,
and the variable DHCP_HOSTNAME does allready exist 
in /etc/sysconfig/network/ifup.

To me it looks like ifup was prepared for this, but this type of initialization 
got dropped in the process somewhere.

I can get it tonight and make the update files available if you are interested.

Comment 2 Raj Selvaraj 2001-09-18 17:27:07 EDT
Thank you, could please Email me the instructions and how to put this 
workaround in my computer.  I have since reinstalled a SERVER type instal but 
the problems still persists.  

Thank you very much.

Raj Gideon Selvaraj
Comment 3 Soren Juelsgaard 2001-09-19 18:40:48 EDT
I made a patch for /etc/sysconfig/network-scripts/network-functions
and for /sbin/ifup to make redhat work with dhcp over cable modems.

You should create a file called /etc/DHCP_HOSTNAME that contains
the hostname you need to use for dhcp to work with your ISP.

For what I know this patch works well, but I would like comments from
other parties (RedHat ??) on this.

To apply the patch to a RedHat 7.1 install, type as root:
patch -p0 <dhcp.patch

Where dhcp.patch contains the following:

*** /etc/sysconfig/network-scripts/network-functions.old	Wed Sep 19 
21:22:06 2001
--- /etc/sysconfig/network-scripts/network-functions	Wed Sep 19 21:26:19 2001
*** 54,61 ****
--- 54,68 ----
+ get_dhcp_hostname()
+ {
+     if [ -f /etc/DHCP_HOSTNAME ]; then
+ 	DHCP_HOSTNAME=`sed 's/:.*//g' /etc/DHCP_HOSTNAME`
+     fi
+ }
      hostname $1
      if ! grep search /etc/resolv.conf >/dev/null 2>&1; then
*** /sbin/ifup.old	Wed Sep 19 21:21:39 2001
--- /sbin/ifup	Wed Sep 19 21:50:52 2001
*** 6,13 ****
--- 6,14 ----
  . network-functions
  . /etc/rc.d/init.d/functions
+ get_dhcp_hostname
  [ -z "${CONFIG}" ] && {

Best Regards,

PS: If you need anymore help, feel free to send me an email.

Comment 4 Soren Juelsgaard 2001-09-19 18:42:59 EDT
Created attachment 32159 [details]
Fixes /etc/DHCP_HOSTNAME for cable modems
Comment 5 Daniel Walsh 2003-08-01 16:35:16 EDT
Going through and cleaning up old bug reports.  Does this problem still exist or
can I close it?  No response will be taken as an affirmative.


Note You need to log in before you can comment on or make changes to this bug.