Bug 536407 - (RHQ-75) add an 'Embedded: yes/no' Trait to the Agent resource
add an 'Embedded: yes/no' Trait to the Agent resource
Status: CLOSED WONTFIX
Product: RHQ Project
Classification: Other
Component: Agent (Show other bugs)
0.1
All All
low Severity medium (vote)
: ---
: ---
Assigned To: Corey Welton
http://jira.rhq-project.org/browse/RH...
: Improvement
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-12 17:20 EDT by Ian Springer
Modified: 2013-12-07 09:33 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-07 09:33:59 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ian Springer 2008-03-12 17:20:00 EDT
(5:08:39 PM) ips: mazz- that would be a handy Trait - Embedded: yes/no
(5:09:11 PM) mazz: assuming the agent knows that :)
(5:09:21 PM) mazz: which, off the top of my head, I don't think it does
(5:12:12 PM) ips: it could figure it out though. look at its own command line and see if it contains "org.rhq.enterprise.agent.AgentMain"
Comment 1 Red Hat Bugzilla 2009-11-10 16:16:23 EST
This bug was previously known as http://jira.rhq-project.org/browse/RHQ-75
Comment 2 Corey Welton 2010-08-12 15:58:21 EDT
mazz - is the info available at the layer it would need to be avail?  if not, we should close this one out
Comment 3 John Mazzitelli 2010-08-24 13:30:08 EDT
I'm sure there are a dozen ways we can figure out if the agent is running embedded in the server (e.g. look in the platform MBeanServer and see if there are any JBossAS related MBeans, use Sigar to see if our process' arguments contain AgentMain or jboss MBain, look at the agent home and see if it matches the standalone setup or the JBoss embedded setup, etc).

However, we don't support the embedded agent and this would be a lesser needed trait. Due to the optional nature of this request and the time it would take to code up for a feature we don't support, I say we close this as WILLNOTFIX. Assigning back to Corey to make the final determination on this one.

Note You need to log in before you can comment on or make changes to this bug.