Bug 536417 - (RHQ-769) allow plugin developers to specify null values for MeasurementDataNumerics
allow plugin developers to specify null values for MeasurementDataNumerics
Status: CLOSED NEXTRELEASE
Product: RHQ Project
Classification: Other
Component: Plugin Container (Show other bugs)
1.0.1
All All
low Severity medium (vote)
: ---
: ---
Assigned To: Ian Springer
Jeff Weiss
http://jira.rhq-project.org/browse/RH...
: Improvement
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-08-30 09:55 EDT by Ian Springer
Modified: 2014-11-09 17:50 EST (History)
2 users (show)

See Also:
Fixed In Version: 1.1.2
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ian Springer 2008-08-30 09:55:00 EDT
A value of null should be allowed to make the APIs more flexible and forgiving. null will have the same meaning as Double.NaN: "no data available"
Comment 1 Ian Springer 2008-08-30 09:56:41 EDT
Done - r1322.
Comment 2 Joseph Marques 2009-04-28 05:00:18 EDT
this was fixed for 1.1.2 but just never resolved.
Comment 3 Jeff Weiss 2009-05-08 11:22:37 EDT
Closing with no testing, since this wasn't put in our queue during the release in which it was fixed.
Comment 4 Red Hat Bugzilla 2009-11-10 16:16:33 EST
This bug was previously known as http://jira.rhq-project.org/browse/RHQ-769

Note You need to log in before you can comment on or make changes to this bug.