This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 536438 - (RHQ-788) Add parent name to resource names when displaying resources in a list
Add parent name to resource names when displaying resources in a list
Status: CLOSED NEXTRELEASE
Product: RHQ Project
Classification: Other
Component: Core UI (Show other bugs)
1.0.1
All All
high Severity medium (vote)
: ---
: ---
Assigned To: Joseph Marques
Corey Welton
http://jira.rhq-project.org/browse/RH...
: Improvement
Depends On: RHQ-348 RHQ-494 RHQ-794 RHQ-795 RHQ-796
Blocks:
  Show dependency treegraph
 
Reported: 2008-09-05 16:01 EDT by Charles Crouch
Modified: 2015-02-01 18:25 EST (History)
1 user (show)

See Also:
Fixed In Version: 1.1
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
singleMetricMultipleResources.jpg (115.71 KB, image/jpeg)
2008-09-05 16:03 EDT, Charles Crouch
no flags Details
groupMetricTab.jpg (142.02 KB, image/jpeg)
2008-09-05 16:04 EDT, Charles Crouch
no flags Details
addCompatibleResourcesToGroup.jpg (71.33 KB, image/jpeg)
2008-09-05 16:06 EDT, Charles Crouch
no flags Details
parent-subtask.jpg (3.02 KB, image/jpeg)
2008-09-05 16:10 EDT, Charles Crouch
no flags Details
groupMetricTab-updated.jpg (48.87 KB, image/jpeg)
2008-09-08 19:56 EDT, Charles Crouch
no flags Details
addCompatibleResourcesToGroup-updated.jpg (72.25 KB, image/jpeg)
2008-09-08 19:59 EDT, Charles Crouch
no flags Details
metricChartDetails_updated.png (36.29 KB, image/png)
2008-09-09 21:01 EDT, Joseph Marques
no flags Details

  None (edit)
Description Charles Crouch 2008-09-05 16:01:00 EDT
A lot of resources which JON manages are given quite simple names by their plugins ,e.g. CPU1 processor, DefaultDS datasource. This proves problematic when groups of these resources are shown in lists, e.g. all the DefaultDS datasources deployed in a set of app servers, or all the CPUs on a set of machines. The problem is that the resource names are not unique enough to show which resource is which in the list. 

In 1.4 we mostly got around this by often putting the parent resource name directly in the name of the resource. This however is not a great solution to the problem as sometimes, e.g. when displaying resources in a hierarchy, you don't need the extra parent information. A better solution would be show the parent name alongside the resource name just when it is needed in list views.

I'll attach some images showing the problem.
Comment 1 Charles Crouch 2008-09-05 16:10:29 EDT
One idea would be to do something similar to what jira does for parent/sub tasks and have the parent resource name placed above that of the subtask. See parent-subtask.jpg
Comment 2 Charles Crouch 2008-09-05 17:56:19 EDT
This was requested by the same customer who raised case: 212918 
Comment 3 Joseph Marques 2008-09-09 20:54:24 EDT
fixed all 5 places were we wanted to add parent context info.  resolving, although this issue doesn't require test - it's just a container.
Comment 4 Corey Welton 2008-09-18 11:06:24 EDT
Closing this tracker -- all supporting issues have been verified.
Comment 5 Red Hat Bugzilla 2009-11-10 16:16:53 EST
This bug was previously known as http://jira.rhq-project.org/browse/RHQ-788
Imported an attachment (id=368897)
Imported an attachment (id=368898)
Imported an attachment (id=368899)
Imported an attachment (id=368900)
Imported an attachment (id=368901)
Imported an attachment (id=368902)
Imported an attachment (id=368903)

Note You need to log in before you can comment on or make changes to this bug.