Bug 536439 - (RHQ-789) Improve organization of links on Saved Charts portlet
Improve organization of links on Saved Charts portlet
Status: CLOSED WONTFIX
Product: RHQ Project
Classification: Other
Component: Core UI (Show other bugs)
1.0.1
All All
low Severity medium (vote)
: ---
: ---
Assigned To: Joseph Marques
Heiko W. Rupp
http://jira.rhq-project.org/browse/RH...
: Improvement
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-09-05 17:08 EDT by Charles Crouch
Modified: 2015-02-01 18:25 EST (History)
3 users (show)

See Also:
Fixed In Version: 1.4
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-10-06 23:10:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Charles Crouch 2008-09-05 17:08:00 EDT
Right now when you save a chart to the dashboard, a link to the chart gets added to Saved Charts portlet. There seems to be no way to order/group the links once they are on the portlet which can be confusing if you have added lot charts.
Comment 1 Charles Crouch 2008-09-05 17:31:18 EDT
This was requested by the same customer who raised case: 212918
Comment 2 Joseph Marques 2009-01-31 22:13:18 EST
rev2876 -  improve organization of saved charts portlet by sorting alphabetically by the saved chart name; 

to test:
* add a bunch of charts to saved charts
* verify that they are alpha-sorted on the dashboard
* click the edit icon and ensure that the edit page is also alpha-sorted
* ensure that you can delete items from the edit page
Comment 3 Heiko W. Rupp 2009-03-17 15:18:51 EDT
The described code is indeed working as described,
but there is still no way to group or sort the entries.

pilhuhn: ccrouch: Are you actually happy with the solution of http://jira.rhq-project.org/browse/RHQ-789 ?
[17:35] ccrouch: pilhuhn: probably not, but i dont recall what my exact dislike was initially. one thing to check is whether we have sufficient uniqueness on the resources in the Saved Charts portlet


Also if you have 2 linux hosts in inventory and put eth0: Bytes received into the saved charts list, you end up with
eth0: Bytes received
eth0: Bytes received(2)
With no indication which is which.
Comment 4 Joseph Marques 2009-03-20 01:46:16 EDT
the saved charts portlet is better than it used to be, but i agree it could be more useful.  however, there simply isn't enough time left in 1.2 timeframe to make the larger improvements this jira is asking for.  pushing this out.
Comment 5 Red Hat Bugzilla 2009-11-10 16:16:55 EST
This bug was previously known as http://jira.rhq-project.org/browse/RHQ-789
Comment 6 Corey Welton 2010-10-06 23:10:04 EDT
Closing per gwt efforts

Note You need to log in before you can comment on or make changes to this bug.