Bug 536466 - (RHQ-811) Entering double-byte characters into affinity group name field results in garbage.
Entering double-byte characters into affinity group name field results in gar...
Status: CLOSED CURRENTRELEASE
Product: RHQ Project
Classification: Other
Component: Core UI (Show other bugs)
1.1pre
All All
low Severity medium (vote)
: ---
: ---
Assigned To: RHQ Project Maintainer
Mike Foley
http://jira.rhq-project.org/browse/RH...
: SubBug
Depends On:
Blocks: RHQ-583
  Show dependency treegraph
 
Reported: 2008-09-09 13:15 EDT by Corey Welton
Modified: 2014-05-02 13:55 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Red Hat Enterprise Linux Server release 5.2 (Tikanga) Kernel \r on an \m Linux rlx-0-12.rhndev.redhat.com 2.6.18-92.1.10.el5 #1 SMP Wed Jul 23 03:55:54 EDT 2008 i686 i686 i386 GNU/Linux java version "1.5.0_16" Java(TM) 2 Runtime Environment, Standard Edit
Last Closed: 2014-05-02 13:55:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Corey Welton 2008-09-09 13:15:00 EDT
1. Administration > High Availability > "???admin.home.Ha.ListAffinityGroups???"
2. Create New
3. Enter a double-byte string ("北京")on the resulting page; hit the Create button [1]

Expected results:
Characters render

Current results:
Non-doublebyte garbage strings for the Affinity Group name. ("北京")


Notes:
Only mention this one because it was noted that doublebyte stuff is generally handled non-uniform across the system due to differing technologies being used. It was indicated, in some manner, that the older stuff was broken, but anything newly developed ought to work.  That doesn't appear to be the case here.

[1] if JIRA can't display the above doublebyte chars:
* Go to http://www.xinhuanet.com/ and copy a few characters to paste into the field.
Comment 1 Red Hat Bugzilla 2009-11-10 16:17:25 EST
This bug was previously known as http://jira.rhq-project.org/browse/RHQ-811
Comment 2 wes hayutin 2010-02-16 11:55:48 EST
Temporarily adding the keyword "SubBug" so we can be sure we have accounted for all the bugs.

keyword:
new = Tracking + FutureFeature + SubBug
Comment 3 wes hayutin 2010-02-16 12:00:51 EST
making sure we're not missing any bugs in rhq_triage

Note You need to log in before you can comment on or make changes to this bug.