Bug 53649 - eepro100: wait_for_cmd_done timeout!
eepro100: wait_for_cmd_done timeout!
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Garzik
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-09-13 17:40 EDT by Telsa Gwynne
Modified: 2013-07-02 22:05 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-06-07 13:41:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Telsa Gwynne 2001-09-13 17:40:26 EDT
Description of Problem:

This is not the stock kernel, it's  2.4.9-ac10 because I needed some 
extra stuff to chase something else. It first arose after I upgraded
the kernel and X from RC-2: the X rpms involved are now XFree86-libs-4.1.0-3
XFree86-4.1.0-3

How Reproducible:

Running GNOME. Leave it. Screensaver ("strange") comes up. Try to 
type in a window, and can't type. I have a serial console atm, luckily.
This (and dmesg) display: 

eepro100: wait_for_cmd_done timeout!
eepro100: wait_for_cmd_done timeout!
eepro100: wait_for_cmd_done timeout!
(lots)
NETDEV WATCHDOG: eth0: transmit timed out
eth0: Transmit timed out: status 0050  0cf0 at 61695/61723 command 000c0000.
eth0: Tx ring dump,  Tx queue 61723 / 61695:

Have omitted the rest because arjan says he doesn't need it. I can
attach it if it helps. 

The machine can be woken back up even though I can't type in X with: 
/etc/rc.d/init.d/network restart
(on the serial console. I didn't think to try to get virtual console
on the monitor with X on)

[hobbit@aloss hobbit]$ /sbin/lspci -n
00:00.0 Class 0600: 8086:1130 (rev 02)
00:02.0 Class 0300: 8086:1132 (rev 02)
00:1e.0 Class 0604: 8086:244e (rev 02)
00:1f.0 Class 0601: 8086:2440 (rev 02)
00:1f.1 Class 0101: 8086:244b (rev 02)
00:1f.2 Class 0c03: 8086:2442 (rev 02)
00:1f.3 Class 0c05: 8086:2443 (rev 02)
00:1f.4 Class 0c03: 8086:2444 (rev 02)
00:1f.5 Class 0401: 8086:2445 (rev 02)
01:08.0 Class 0200: 8086:2449 (rev 01)
[hobbit@aloss hobbit]$
Comment 1 Brent Nordquist 2001-10-16 13:01:06 EDT
I'm seeing these with 7.2 gold, and also after updating to 2.4.9-0.20.2 (both
stock kernels).  This machine has the NIC right on the (Intel 815-based)
motherboard.  Usually the network hangs and clears in 2-5 minutes, but on two
occasions it's locked the machine up.  (I guess I'm testing ext3 ;-).)

My lspci -n:

00:00.0 Class 0600: 8086:1130 (rev 02)
00:01.0 Class 0604: 8086:1131 (rev 02)
00:1e.0 Class 0604: 8086:244e (rev 02)
00:1f.0 Class 0601: 8086:2440 (rev 02)
00:1f.1 Class 0101: 8086:244b (rev 02)
00:1f.2 Class 0c03: 8086:2442 (rev 02)
00:1f.3 Class 0c05: 8086:2443 (rev 02)
00:1f.4 Class 0c03: 8086:2444 (rev 02)
00:1f.5 Class 0401: 8086:2445 (rev 02)
01:08.0 Class 0200: 8086:2449 (rev 01)
01:0d.0 Class 0100: 9004:8178
02:00.0 Class 0300: 1002:4742 (rev 5c)

More data on request.

Comment 2 Arjan van de Ven 2001-10-16 13:04:52 EDT
Is this also 10 mbit half duplex ?
Comment 3 Brent Nordquist 2001-10-16 14:16:42 EDT
If so, it isn't by design... the switch it's plugged into is 100mbit FDx capable.

How would I tell?  I don't see anything in dmesg or /var/log/messages that seems
to indicate one way or the other.
Comment 4 Mike A. Harris 2002-09-11 17:42:00 EDT
Blame it on jwz!

;o)
Comment 5 Jeff Garzik 2002-10-25 14:28:54 EDT
Is this reproducible on 8.0 or a stock kernel.org kernel?
Hopefully we have killed this problem, but I need confirmation...

Note You need to log in before you can comment on or make changes to this bug.