Bug 53655 - Problem after upgrading from 7.1
Problem after upgrading from 7.1
Status: CLOSED NOTABUG
Product: Red Hat Public Beta
Classification: Retired
Component: net-tools (Show other bugs)
roswell
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Phil Knirsch
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-09-13 22:32 EDT by Need Real Name
Modified: 2015-03-04 20:09 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-12-08 06:46:33 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2001-09-13 22:32:53 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.3) Gecko/20010802

Description of problem:
Hi, the problem is pretty simple..
I upgraded from RH 7.1 to roswell beta 2 and then run the up2date to be
updated up to the minute - now my network stopped working..

All what I get right now when I'm trying /sbin/services network start - I
get "illegal seek". example:

 kde21]# /etc/rc.d/init.d/network restart
Shutting down interface eth0:                              [  OK  ]
Setting network parameters:                                [  OK  ]
Bringing up interface lo:                                  [  OK  ]
Cannot open netlink socket: Illegal seek

in /var/log/messaes it looks like this:

Sep 14 05:18:20 badboy network: Shutting down interface eth0:  succeeded
Sep 14 05:18:20 badboy sysctl: net.ipv4.ip_forward = 0
Sep 14 05:18:20 badboy sysctl: net.ipv4.conf.all.rp_filter = 0
Sep 14 05:18:20 badboy sysctl: kernel.sysrq = 1
Sep 14 05:18:20 badboy network: Setting network parameters:  succeeded
Sep 14 05:18:20 badboy ifup: Cannot open netlink socket: Invalid argument
Sep 14 05:18:20 badboy network: Bringing up interface lo:  succeeded



Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.install RH 7.1
2.upgrade to 2nd beta
3.have this problem ;(

I managed to have this problem on this machine only. Didn't hear about
other people having those problems

Additional info:

output of /etc/sysconfig/network-scripts/ifcfg-eth0

DEVICE=eth0
ONBOOT=yes
BOOTPROTO=static
IPADDR=192.168.1.2
NETMASK=255.255.255.0
GATEWAY=192.168.1.1
TYPE=Ethernet
USERCTL=no
NETWORK=192.168.1.0
BROADCAST=192.168.1.255
PEERDNS=no

RPMS related: glibc-2.2.4-11, initscripts-6.32-1, net-tools 1.60-3
Comment 1 Bill Nottingham 2001-09-26 11:37:23 EDT
It sounds like you rebuilt your kernel without NETLINK and RTNETLINK support -
is that the case?
Comment 2 Hetz Ben Hamo 2001-12-08 06:46:28 EST
Wow, I thought that this bug was closed long time ago. 
Yes, you were right and I handled that long time ago, but I thought I asked to 
close this bug.

Could you close it please?

Thanks,
Hetz
Comment 3 Phil Knirsch 2001-12-08 08:46:15 EST
Closed as requested ;-).

Read ya, Phil

Note You need to log in before you can comment on or make changes to this bug.