Bug 536583 - (RHQ-918) InventoryManager.mergeResource(Resource) can be optimized significantly when passed an unknown Resource tree
InventoryManager.mergeResource(Resource) can be optimized significantly when ...
Status: CLOSED CURRENTRELEASE
Product: RHQ Project
Classification: Other
Component: Plugin Container (Show other bugs)
1.0.1
All All
medium Severity medium (vote)
: ---
: ---
Assigned To: RHQ Project Maintainer
Mike Foley
http://jira.rhq-project.org/browse/RH...
: FutureFeature, Improvement
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-02 08:30 EDT by Ian Springer
Modified: 2014-05-15 17:32 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-05-15 17:32:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ian Springer 2008-10-02 08:30:00 EDT
On the recursive calls to mergeResource(), the call to findMatchingChildResource() to find an existing child Resource need not be made at all, since it will always return the same Resource that is being merged (since its parent was just added to inventory). This will also eliminate the need to execute the (existingResource != null) if-block.
Comment 1 Red Hat Bugzilla 2009-11-10 16:19:36 EST
This bug was previously known as http://jira.rhq-project.org/browse/RHQ-918
Comment 2 wes hayutin 2010-02-16 12:08:15 EST
mass add of key word FutureFeature to help track
Comment 3 Corey Welton 2010-10-05 09:37:18 EDT
Triaged 30-Sep

Note You need to log in before you can comment on or make changes to this bug.