Bug 536650 - (RHQ-979) persist inventory.dat earlier
persist inventory.dat earlier
Status: CLOSED WONTFIX
Product: RHQ Project
Classification: Other
Component: Plugin Container (Show other bugs)
1.1
All All
high Severity medium (vote)
: ---
: ---
Assigned To: John Mazzitelli
http://jira.rhq-project.org/browse/RH...
: FutureFeature, Improvement
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-14 13:02 EDT by John Mazzitelli
Modified: 2014-05-15 17:51 EDT (History)
2 users (show)

See Also:
Fixed In Version: 1.4
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-05-15 17:51:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Mazzitelli 2008-10-14 13:02:00 EDT
when you start the agent, there is no inventory.dat file.  After the agent gets resources in inventory, I noticed there still isn't any data/inventory.dat file.  Only when you shutdown, will that file get written.

If the agent crashed prior to shutdown, it will never have persisted its inventory - if the agent then comes up but there is no server available for the agent to sync with, the agent will not be able to monitor its resources because it will not have inventory.

We should consider having the agent persist the inventory.dat earlier in its lifecycle.
Comment 1 John Mazzitelli 2008-11-06 02:04:32 EST
I'm raising this to major for possible fixing in 1.2. Here's why:

Typically, you install an agent and forget it.  you normally won't shut it down after the inventory is finally synced. it just runs "forever". But if the server crashes or otherwise is brought down harshly, the inventory.dat will never get written out and you will have to re-sync the next time its started.  And the loop continues - since inventory.dat isn't persisted in a timely manner, the cycle will continue - agent runs until its brought down and if its not brough down nicely, the inventory.dat won't get written.
Comment 2 Charles Crouch 2009-09-01 10:52:31 EDT
Moving features/improvements to 1.4
Comment 3 Red Hat Bugzilla 2009-11-10 16:20:52 EST
This bug was previously known as http://jira.rhq-project.org/browse/RHQ-979
Comment 4 wes hayutin 2010-02-16 12:08:55 EST
mass add of key word FutureFeature to help track
Comment 5 Corey Welton 2010-10-05 09:30:09 EDT
mazz - what would it take to fix this?
Comment 6 John Mazzitelli 2010-10-05 09:44:29 EDT
when I last looked, this was not going to be trivial to do. We'd have to pick a time to write inventory.dat, and anytime inventory changes (added/removed/modified a resource) we probably would want to write it out again. Unsure how easy it would be to do this and how long it would take to implement, but it would be a good idea to keep inventory.dat updated throughout the lifetime of the agent.

Note You need to log in before you can comment on or make changes to this bug.