Bug 53666 - X11 server crashes with signial 11 caught
X11 server crashes with signial 11 caught
Status: CLOSED NOTABUG
Product: Red Hat Public Beta
Classification: Retired
Component: XFree86 (Show other bugs)
roswell
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-09-14 08:27 EDT by adler
Modified: 2007-04-18 12:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-10-15 16:51:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description adler 2001-09-14 08:27:15 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.2) Gecko/20010809

Description of problem:
The X11 server verion 4.x crashes randomly with signal #11 being caught by
the server and forcing the servier to exit.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Run X11
2.Wait, sometimes a day or two
3.What your windows disapear
	

Additional info:

It looks like this problem is coupled to the IRQ of the vga contoller card.
It also looks like an SMP problem. I have found a workaround. Currently I
have a dual intel SMP system which uses the VIA chipset. I observe the
following regarding this bug.

1) Running full SMP, with IRQ enabled in the card and "dri" loaded into X11
server. (This is my default way of running my system.) X11 would crash on
signal 11 when in active use. (i.e. my clicking around mozilla, reading
e-mail, listening to mp3s etc.) When I left the system alone and the screen
saver took over, the system would either hard freeze or the X11 server
would die.

2) Running in uniprocessor mode, with IRQ enabled and "dri" loaded, same
result.

3) SMP running with IRQ *disabled* and "dri" not laoded, same result

4) Uniprocessor mode, with IRQ disabled and "dri" not loaded. Works!!!!

I have a strong suggestion. Can you please try running X11 on an SMP
system, and turn on the IRQ and make sure "dri" is loaded. You may be able
to reproduce this bug.
Comment 1 Mike A. Harris 2001-09-18 04:26:19 EDT
I run X 24/7 on 2 SMP servers and have never had a crash.
I'm unable to do anything at all without proper full bug report data however,
including knowing what video card you're using, as well as config files,
X server logs, kernel "messages" log (trimmed and privatized if necessary)
all submitted as file attachments using the link below.

Comment 2 Mike A. Harris 2001-10-15 05:19:50 EDT
Please supply requested info.
Comment 3 adler 2001-10-15 16:51:10 EDT
I'm very swamped with work right now. I'll try and get back to you. Currently
I'm running in non-smp mode, with video card interupts disabled and X11 is very
stable this way. My time scale to getting back to this problem is about 1 month.
Sorry for not being more forth coming with this.
Comment 4 Mike A. Harris 2001-11-01 07:19:42 EST
Closing bug, no information to go on.  Reopen bug when information
is available if you like.

Thanks

Note You need to log in before you can comment on or make changes to this bug.