Bug 536778 - "Failed to apply network settings", and Bluetooth NAP doesn't work
"Failed to apply network settings", and Bluetooth NAP doesn't work
Status: CLOSED DUPLICATE of bug 533720
Product: Fedora
Classification: Fedora
Component: blueman (Show other bugs)
12
All Linux
low Severity high
: ---
: ---
Assigned To: Juan Manuel Rodriguez
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-11-11 05:52 EST by Bradley
Modified: 2009-11-11 05:56 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-11-11 05:56:23 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bradley 2009-11-11 05:52:49 EST
Description of problem:

After updating from F11 to F12, when logging in, I get a dialog box with the text:

"Failed to apply network settings

org.freedesktop.DBus.Error.ServiceUnknown: The name :1.62 was not provided by any .service files

You might not be able to connect to the Bluetooth network via this machine"

and I can't connect to my (non-jailbroken Australian iPhone)

Version-Release number of selected component (if applicable):

blueman-1.10-4.fc12.x86_64

How reproducible:

Always. the 'name' changes for each login, though

Steps to Reproduce:
1. Log in
2. See dialog box
3. Try to connect. Fail.
  
Actual results:

Get dialog box on login. Can't connect to my (Australian non-jailbroken) iPhone to tether - when I try I immediately get:

ERROR:dbus.connection:Exception in handler for D-Bus signal:
Traceback (most recent call last):
  File "/usr/lib/python2.6/site-packages/dbus/connection.py", line 214, in maybe_handle_message
    self._handler(*args, **kwargs)
  File "/usr/lib/python2.6/site-packages/blueman/plugins/applet/Networking.py", line 84, in on_network_prop_changed
    m.HalRegisterNetDev(value)
  File "/usr/lib/python2.6/site-packages/dbus/proxies.py", line 68, in __call__
    return self._proxy_method(*args, **keywords)
  File "/usr/lib/python2.6/site-packages/dbus/proxies.py", line 140, in __call__
    **keywords)
  File "/usr/lib/python2.6/site-packages/dbus/connection.py", line 630, in call_blocking
    message, timeout)
DBusException: org.freedesktop.DBus.Error.ServiceUnknown: The name :1.62 was not provided by any .service files

logged if I start the applet from an xterm

Expected results:

No dialog box, can tether.

Additional info:

There isn't a title on the dialog box to let me know who is reporting this error, but if I xkill that blueman-applet logs the error to the .xsession-errors file.
Comment 1 Bradley 2009-11-11 05:56:23 EST
Actually, found this is a dupe

*** This bug has been marked as a duplicate of bug 533720 ***

Note You need to log in before you can comment on or make changes to this bug.