Bug 53687 - Raidstart fails on Boot
Summary: Raidstart fails on Boot
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: raidtools (Show other bugs)
(Show other bugs)
Version: 7.3
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Matt Wilson
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-09-15 01:58 UTC by Thornton Prime
Modified: 2007-04-18 16:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-09-15 01:58:47 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Thornton Prime 2001-09-15 01:58:43 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.78 [en] (X11; U; Linux 2.4.7-10 i686; Nav)

Description of problem:
Raidstart fails on boot when raid devices are not marked with partition
types 'fd' (raid autostart) and /usr is not on the boot partition because
/sbin/raidstart is dynamically linked against popt

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Partition so /usr is not on your boot drive
2. Create a raid partition not using 'fd' autostart partition types
3. Reboot. raidstart in rc.sysinit will fail because it is linked against
popt, and popt is in /usr/lib
	

Additional info:

Are there other applications dynamically linked against popt that might be
required for booting?

Comment 1 Bill Nottingham 2001-09-26 15:46:15 UTC
Fixed in 0.90-24.


Note You need to log in before you can comment on or make changes to this bug.