Bug 53689 - ncftp 3.0.1/3.0.3 does not do PASV mode no matter what
Summary: ncftp 3.0.1/3.0.3 does not do PASV mode no matter what
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: ncftp (Show other bugs)
(Show other bugs)
Version: 7.0
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Bernhard Rosenkraenzer
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-09-15 09:47 UTC by matti aarnio
Modified: 2008-05-01 15:38 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-03-13 13:06:27 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description matti aarnio 2001-09-15 09:47:02 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.76 [en] (X11; U; Linux 2.4.3-ac14 i686)

Description of problem:
Working from behind a firewall allowing only connections outwards means
I need to have the PASV mode working at the FTP client.
It hasn't worked at any of ncftp 3.x versions I have tried.

I vaguely think that it used to work...


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. connect to some FTP server
2. "debug 1"
3. observe ncftp to send PORT command for every file/directory access
    independent of what is the "passive" setting.
4. If you have a firewall (like I) with only the outgoing connections
allowed, you
    won't see e.g. directory listings, nor be able to retrieve files.
	

Actual Results:  The PORT  protocol verb is sent.


Expected Results:  The PASV protocol verb should appear.


Additional info:

This appeared at RH 7.0's version of ncftp, and with current RawHide ncftp.
I can't say if this appears with RH 6.2's ncftp.

Comment 1 Pekka Savola 2002-03-13 12:56:10 UTC
This works for me.  I tested RHL72 version (3.0.2-2) and a later version
(3.0.3-6 with IPv6),
both appear to honour 'set passive on' and 'set passive off' settings like you
described.


Comment 2 matti aarnio 2002-03-13 13:06:23 UTC
I had forgotten this..

It looks like at some point latter, updating glibc  bought the systemback into
sanity, and the PASV works again.



Note You need to log in before you can comment on or make changes to this bug.