Bug 536930 - Multiple "reboot" messages that keep coming back even when closed.
Multiple "reboot" messages that keep coming back even when closed.
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kpackagekit (Show other bugs)
12
All Linux
low Severity medium
: ---
: ---
Assigned To: Steven M. Parrish
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-11-11 15:08 EST by Justin Newman
Modified: 2009-11-27 16:38 EST (History)
7 users (show)

See Also:
Fixed In Version: 0.5.1.1-1.fc12
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-11-27 16:38:07 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
4 reboot requests (368.08 KB, image/png)
2009-11-11 15:08 EST, Justin Newman
no flags Details

  None (edit)
Description Justin Newman 2009-11-11 15:08:04 EST
Created attachment 369100 [details]
4 reboot requests

Description of problem: When doing updates that request a reboot I get multiple warnings for the same update. I can close these warnings (or click not now), but they come back when I do *anything* with kpackagekit, whether it's search for a package, refresh the package list, open it, etc.


Version-Release number of selected component (if applicable): kpackagekit-0.5.0.3-1.fc12.x86_64


How reproducible: Simple install an update that requires reboot or log out with kpackagekit. Multiple reboot requests should pop up. Close them and continue to use kpackagekit to see them reappear.
  
Expected results: Only one reboot warning for updates. Also, if I close or say "not now" there should be a minimum time before the message can be displayed again. perhaps an our or so... maybe never. I feel like a Windows user with this level of nagging. :p
Comment 1 Justin Newman 2009-11-11 15:08:38 EST
Different than bug #521236, but maybe related? I don't know.
Comment 2 Rex Dieter 2009-11-11 15:28:03 EST
Yes, related, and honestly, I thought was going to get addressed in 0.5.x, but maybe not. :(
Comment 3 Richard Hughes 2009-11-12 04:39:43 EST
(In reply to comment #2)
> Yes, related, and honestly, I thought was going to get addressed in 0.5.x, but
> maybe not. :(  

Not a PackageKit bug, a kpackagekit bug.
Comment 4 Steven M. Parrish 2009-11-17 08:15:21 EST
Yes this was supposedly fixed in 0.5.x, and strangely I cannot reproduce on my system. Can anyone confirm this?
Comment 5 Rex Dieter 2009-11-17 09:10:32 EST
I think I've seen it relatively recently, though I can't say for certain the exact version of kpk I had installed at the time.  It was during F12-beta somewhere.
Comment 6 Fedora Update System 2009-11-17 16:37:45 EST
kpackagekit-0.5.1.1-1.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/kpackagekit-0.5.1.1-1.fc12
Comment 7 Fedora Update System 2009-11-20 00:26:12 EST
kpackagekit-0.5.1.1-1.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update kpackagekit'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F12/FEDORA-2009-11791
Comment 8 Fedora Update System 2009-11-27 16:37:53 EST
kpackagekit-0.5.1.1-1.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.