Bug 53700 - pump doesnt work with RoadRunner, violates RFC
pump doesnt work with RoadRunner, violates RFC
Status: CLOSED DUPLICATE of bug 23052
Product: Red Hat Linux
Classification: Retired
Component: pump (Show other bugs)
7.1
All Linux
medium Severity high
: ---
: ---
Assigned To: Elliot Lee
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-09-15 14:32 EDT by Mario Lorenz
Modified: 2008-05-01 11:38 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-09-17 06:13:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mario Lorenz 2001-09-15 14:32:17 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.77 [de] (X11; U; Linux 2.4.5-SGI_XFS_1.0.1 i686)

Description of problem:
This is basically a "reopen" of #52436
The problem is that pump is violating the DHCP RFC by not sending
DHCPDISCOVER (and probably other packets as well) with a source
IP of 0.0.0.0 (as required by the RFC) but with the IP of other interfaces
initialized earlier (in my case it used an 192.168.1.x IP from the internal
network). 
RR seems to have implemented IP source filters or IP source verification so
192.168.x sourced IP's will not be accepted (hence not 
given to the DHCP server).
Using dhcpcd, things work fine as dhcpcd properly uses 0.0.0.0 as
source IP until it has given its IP from the DHCP server.
I have tried all versions of pump up to Rawhide (0.8.11-7)

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Get computer with two NIC's
2. ifconfig eth0 192.168.1.1  (for example)
3. ifconfig eth1 up           (so you can do step 4)
4. tcpdump -eni eth1           (to watch. Better use tethereal if
available)
5. /sbin/pump -i eth1
6 (optional) /sbin/dhcpcd eth1  (to compare...)

Actual Results:  tcpdump shows DHCP packets on eth1 (DHCPDISCOVER). They
bear a source
IP of 192.168.1.1.

Expected Results:  DHCP RFC mandates a source IP of 0.0.0.0.


Additional info:
Comment 1 Olivier Baudron 2001-09-17 06:13:17 EDT
See also bug 23052 for further infos (same bug).
Comment 2 Mario Lorenz 2001-09-17 14:49:46 EDT
Indeed, its the same bug as 23052. Probably 52436 should now also be marked
duplicate to that bug. 

*** This bug has been marked as a duplicate of 23052 ***

Note You need to log in before you can comment on or make changes to this bug.