Bug 53701 - Failure: rpm -ivh kdebase-2.2-10.i386.rpm
Failure: rpm -ivh kdebase-2.2-10.i386.rpm
Status: CLOSED WONTFIX
Product: Red Hat Raw Hide
Classification: Retired
Component: rpm (Show other bugs)
1.0
i386 Linux
high Severity high
: ---
: ---
Assigned To: Jeff Johnson
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-09-15 16:35 EDT by Jaroslaw Sosnicki
Modified: 2005-10-31 17:00 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-09-18 05:25:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jaroslaw Sosnicki 2001-09-15 16:35:36 EDT
Description of Problem:

# ls -al kdebase*
-rw-r--r--   21 root     root     18249765 Sep  8 08:31 kdebase-2.2-10.i386.rpm
[root@ns2 RPMS]# rpm -ivh  kdebase-2.2-10.i386.rpm
Preparing...                ########################################### [100%]
   1:kdebase                warning: /etc/X11/gdm/Sessions/KDE created as
/etc/X11/gdm/Sessions/KDE.rpmnew
warning: /etc/kderc created as /etc/kderc.rpmnew
warning: /etc/ksysguarddrc created as /etc/ksysguarddrc.rpmnew
warning: /etc/pam.d/kde created as /etc/pam.d/kde.rpmnew
warning: /etc/pam.d/kscreensaver created as /etc/pam.d/kscreensaver.rpmnew
error: unpacking of archive failed on file /usr/share/config/kdm: cpio:
rename failed - Is a directory

Note: Same problem with enigma release kdebase-2.2-12.i386.rpm

Version-Release number of selected component (if
rawhide-release-20010914-1.noarch.rpm (all packages)
kdebase-2.2-10.i386.rpm


How Reproducible:


Steps to Reproduce:
1. 
2. 
3. 

Actual Results:


Expected Results:


Additional Information:
Comment 1 Bernhard Rosenkraenzer 2001-09-17 10:59:35 EDT
Remove the /usr/share/config/kdm directory first - it's supposed to be a 
symlink
Comment 2 Jaroslaw Sosnicki 2001-09-17 12:47:34 EDT
It looks that you have typo in instalation scripts.
I removed directory /usr/share/config/kdm
I run
# rpm -Uvh kdebase-2.2-10.i386.rpm

/usr/share/config/kdm shows up as a diretory.
In additiona I have links in /usr/share/config as follows
---
lrwxrwxrwx    1 root     root           20 Aug 23 16:36
/usr/share/config/kdm;3b859377 -> ../../../etc/kde/kdm
lrwxrwxrwx    1 root     root           20 Aug 28 09:41
/usr/share/config/kdm;3b8bc990 -> ../../../etc/kde/kdm
lrwxrwxrwx    1 root     root           20 Sep  4 18:41
/usr/share/config/kdm;3b9581e4 -> ../../../etc/kde/kdm
lrwxrwxrwx    1 root     root           20 Sep  4 18:46
/usr/share/config/kdm;3b9583df -> ../../../etc/kde/kdm
lrwxrwxrwx    1 root     root           20 Sep  7 08:53
/usr/share/config/kdm;3b98ed58 -> ../../../etc/kde/kdm
lrwxrwxrwx    1 root     root           20 Sep 15 13:48
/usr/share/config/kdm;3ba3be81 -> ../../../etc/kde/kdm
lrwxrwxrwx    1 root     root           20 Sep 15 13:49
/usr/share/config/kdm;3ba3bedd -> ../../../etc/kde/kdm
lrwxrwxrwx    1 root     root           20 Sep 15 13:51
/usr/share/config/kdm;3ba3bf2a -> ../../../etc/kde/kdm
lrwxrwxrwx    1 root     root           20 Sep 15 13:59
/usr/share/config/kdm;3ba3c13b -> ../../../etc/kde/kdm
lrwxrwxrwx    1 root     root           20 Sep 15 14:00
/usr/share/config/kdm;3ba3c15b -> ../../../etc/kde/kdm
lrwxrwxrwx    1 root     root           20 Sep 15 14:01
/usr/share/config/kdm;3ba3c182 -> ../../../etc/kde/kdm
lrwxrwxrwx    1 root     root           20 Sep 15 14:01
/usr/share/config/kdm;3ba3c1a6 -> ../../../etc/kde/kdm
lrwxrwxrwx    1 root     root           20 Sep 16 15:03
/usr/share/config/kdm;3ba521bf -> ../../../etc/kde/kdm

/usr/share/config/kdm:
total 19
drwxr-xr-x    2 root     root         1024 Sep 16 15:03 .
drwxr-xr-x    5 root     root         2048 Sep 16 15:03 ..
-rw-r--r--    1 root     root        14848 Sep  3 12:11 kdmrc

It's a BUG!!!
Comment 3 Jaroslaw Sosnicki 2001-09-17 23:55:18 EDT
the same problem exist in kdebase-2.2.1-1.i386.rpm

Comment 4 Bernhard Rosenkraenzer 2001-09-18 05:25:46 EDT
Found the problem, and fixed it in 2.2.1-2.

The problem is that the directory got changed to a symlink after the file list 
had been generated, so the file list had %dir /usr/share/config/kdm even 
though it's a symlink.

Assigning to rpm because rpm IMO should have bailed out during the build 
process with this spec file error.
Comment 5 Jeff Johnson 2001-09-20 01:22:08 EDT
%dir in a spec file is an indication not to include
members, not a claim of file type.

Note You need to log in before you can comment on or make changes to this bug.