Bug 53703 - 'rpm --nodeps -e pkg' doesn't work but 'rpm -e pkg --nodeps' does
'rpm --nodeps -e pkg' doesn't work but 'rpm -e pkg --nodeps' does
Status: CLOSED DUPLICATE of bug 51108
Product: Red Hat Raw Hide
Classification: Retired
Component: rpm (Show other bugs)
1.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Johnson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-09-15 19:24 EDT by rosa
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-09-15 19:24:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description rosa 2001-09-15 19:24:55 EDT
See summary 
How to reproduce:
(libao is just an example)

~# rpm -q libao
libao-0.8.0-1
~# rpm -e libao
error: removing these packages would break dependencies:
        libao = 0.8.0 is needed by libao-devel-0.8.0-1
~# rpm --nodeps -e libao
error: removing these packages would break dependencies:
        libao = 0.8.0 is needed by libao-devel-0.8.0-1
~# rpm --force --nodeps -e libao
error: removing these packages would break dependencies:
        libao = 0.8.0 is needed by libao-devel-0.8.0-1
~# rpm -e libao --nodeps
~# rpm -q libao          
package libao is not installed
~# rpm -q rpm
rpm-4.0.3-1.03a
~# rpm -q popt
popt-1.6.3-1.03a

Same with the rpm-4.0.3-1.03.i386.rpm, popt-1.6.3-1.03.i386.rpm
from ftp://ftp.rpm.org/pub/rpm/test-4.0.3
In 53369 you say the latest rpm version is on rawhide but I couldn't
find it there as of today, Sept 16th.

There is an rpm-4.0.3-1.03a.src.rpm on rawhide though, but it's a bit 
hard to find in the s390/ subdir. I had to rebuild that from source 
(lacking an s390:() so if the error would have existed only with that 
version it could also have had other causes.
Comment 1 Jeff Johnson 2001-09-16 09:27:11 EDT

*** This bug has been marked as a duplicate of 51108 ***

Note You need to log in before you can comment on or make changes to this bug.