Bug 53730 - Bad: FIC 503+ VIA chipset install problem
Bad: FIC 503+ VIA chipset install problem
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.1
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Arjan van de Ven
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-09-17 07:56 EDT by Tony Travis
Modified: 2007-04-18 12:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-09-24 15:53:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
/tmp/syslog from 'rescue' boot of 503+ system (5.17 KB, text/plain)
2001-09-20 11:34 EDT, Tony Travis
no flags Details

  None (edit)
Description Tony Travis 2001-09-17 07:56:37 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:0.9.3)
Gecko/20010801

Description of problem:
Installation crashes randomly during installation or post-install phase.
Checked readability of CDROM under Win98 on same system - OK. Tested RH7.1
installation using graphical and text installation. In text installation
Alt+F2 to shell and IDE drives are not functioning including CDROM drive,
but Linux still running. Tried manual/automatic partitioning and e2fsck
from 'rescue' boot. Partition table + FS OK.  Same system installs 'Storm'
Linux (Debian-based) successfully from IDE CDROM to IDE hard disk in ~20
mins. RH 7.1 estimated installation time ~6 mins. Wonder if it's a VIA
chipset UDMA problem?

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Boot from CDROM
2.follow default choices for text/graphical install
	

Actual Results:  Sometimes reach post-install phase, always crash

Expected Results:  Automatic re-boot after post-install scripts run

Additional info:

Flashed BIOS on FIC 503+ to JE439 (latest BIOS) - Win98, RH5 and Storm 2000
(Debian) Linux all install and work fine on the same system. BIOS is not
Win2K compatible according to Win2K installer.
Comment 1 Matt Wilson 2001-09-17 10:40:14 EDT
try booting with "linux ide=nodma" at the boot: prompt
Comment 2 Tony Travis 2001-09-20 11:34:15 EDT
Created attachment 32218 [details]
/tmp/syslog from 'rescue' boot of 503+ system
Comment 3 Tony Travis 2001-09-20 11:36:05 EDT
Booting with ide=nodma did not cure the problem
Comment 4 Brent Fox 2001-09-21 12:13:23 EDT
Did you verify the md5sums of the ISO's before burning them?
Comment 5 Tony Travis 2001-09-24 15:00:12 EDT
Used cygwin md5sum to verify iso images - correct.
Used Windows 'CDcheck' to verify readability of CD-R's - no errors.
Installed on different system from same CD-R's using same CD R/W drive - success.
Comment 6 Brent Fox 2001-09-24 15:06:45 EDT
Weird.  When you said in your first post that "IDE drives are not functioning,
including the cdrom", what exactly does that mean?
Comment 7 Tony Travis 2001-09-24 15:42:21 EDT
I monitored the progress of the 'text' mode install from an alt+2 virtual tty
and the system was working fine until the install crashed. Then, for a short
time, my shell still appeared to be working but none of the IDE drives including
the IDE CDROM drive were resonding. This 503+ based system works fine under RH5,
or debian Linux - I've got two of these 503+ motherboards - both fail to install
RH7.1. The install is very quick (unless I use ide=nodma) but the system seems
to be unstable and crashes randomly during the install. On one occasion I got as
far as the post-install scripts. I used different RAM and a different HD in each
503+ system when I tried to install RH7.1. The second 503+ system I used runs
Win98 reliably.
Comment 8 Brent Fox 2001-09-24 15:53:12 EDT
Hmm.  Since this seems to be motherboard specific, I'm going to change the
component to the kernel.  Perhaps there's something with the driver that's
causing the system to hang.
Comment 9 Tony Travis 2001-09-27 12:01:07 EDT
Workaround: Substitute UDMA2-capable hard disk drive (WD Caviar AC22500L) for
UDMA3 drive. System now installs and runs RH 7.1 (Seawolf) reliably. Not sure if
this is a VIA chipset problem, but system runs Win98 reliably with VIA Win98
UDMA driver.

Note You need to log in before you can comment on or make changes to this bug.